]> git.pld-linux.org Git - packages/php-pecl-archive.git/blob - php-pecl-archive.spec
add module load test
[packages/php-pecl-archive.git] / php-pecl-archive.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname         archive
7 %define         status          beta
8 Summary:        %{modname} - manipulate tar/cpio archives
9 Summary(pl.UTF-8):      %{modname} - obróbka archiwów tar/cpio
10 Name:           %{php_name}-pecl-%{modname}
11 Version:        0.3.1
12 Release:        1
13 License:        PHP 3.01
14 Group:          Development/Languages/PHP
15 Source0:        http://pecl.php.net/get/%{modname}-0.2.tgz
16 # Source0-md5:  1b121440b2c460b2a1af46e31f23e46e
17 Patch100:       branch.diff
18 URL:            http://pecl.php.net/package/archive/
19 BuildRequires:  %{php_name}-devel >= 3:5.0.4
20 BuildRequires:  libarchive-devel
21 BuildRequires:  rpmbuild(macros) >= 1.650
22 %{?with_tests:BuildRequires:    %{php_name}-cli}
23 %{?requires_php_extension}
24 Provides:       php(%{modname}) = %{version}
25 Obsoletes:      php-pecl-archive < 0.2-17
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 archive extension allows to read and write tar and cpio archives using
30 libarchive.
31
32 In PECL status of this extension is: %{status}.
33
34 %description -l pl.UTF-8
35 Rozszerzenie archive pozwala na odczyt i zapis archiwów tar oraz cpio
36 przy użyciu biblioteki libarchive.
37
38 To rozszerzenie ma w PECL status: %{status}.
39
40 %prep
41 %setup -qc
42 mv %{modname}-*/* .
43 %patch100 -p1
44
45 %build
46 phpize
47 %configure
48 %{__make}
49
50 %if %{with tests}
51 # simple module load test
52 %{__php} -n \
53         -dextension_dir=modules \
54         -dextension=%{modname}.so \
55         -m > modules.log
56 grep %{modname} modules.log
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
62 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
63 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
64 ; Enable %{modname} extension module
65 extension=%{modname}.so
66 EOF
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 %php_webserver_restart
73
74 %postun
75 if [ "$1" = 0 ]; then
76         %php_webserver_restart
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc API.txt CREDITS tests
82 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
83 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.115806 seconds and 3 git commands to generate.