]> git.pld-linux.org Git - packages/php-pecl-apd.git/blob - php-pecl-apd.spec
- add missing provides
[packages/php-pecl-apd.git] / php-pecl-apd.spec
1 %define         _modname        apd
2 %define         _status         stable
3 Summary:        %{_modname} - full-featured engine-level profiler/debugger
4 Summary(pl):    %{_modname} - w pe³ni funkcjonalny profiler/debugger dla PHP
5 Name:           php-pecl-%{_modname}
6 Version:        1.0.1
7 Release:        6
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  470ea75cde09f7504c83441911c86f29
12 Patch0:         %{name}-build_fix.patch
13 URL:            http://pecl.php.net/package/apd/
14 BuildRequires:  php-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_zend_extension}
17 Requires:       php-common >= 4:5.0.4
18 Obsoletes:      php-pear-%{_modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 APD is a full-featured profiler/debugger that is loaded as a
23 zend_extension. It aims to be an analog of C's gprof or Perl's
24 Devel::DProf.
25
26 In PECL status of this package is: %{_status}.
27
28 %description -l pl
29 APD to w pe³ni funkcjonalny profiler/debugger ³adowany jako
30 rozszerzenie Zend. Ma byæ odpowiednikiem gprof z C lub perlowego
31 Devel::DProf.
32
33 To rozszerzenie ma w PECL status: %{_status}.
34
35 %prep
36 %setup -q -c
37 %patch0 -p1
38
39 %build
40 cd %{_modname}-%{version}
41 phpize
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
48
49 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
50 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
51 ; Enable %{_modname} extension module
52 zend_extension%{?zend_zts:_ts}=%{_modname}.so
53 EOF
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %php_webserver_restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         %php_webserver_restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc %{_modname}-%{version}/README
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.093811 seconds and 3 git commands to generate.