]> git.pld-linux.org Git - packages/php-pecl-amfext.git/blob - php-pecl-amfext.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-amfext.git] / php-pecl-amfext.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname amfext
3 %define         status          beta
4 Summary:        %{modname} - ActionScript Message Format extension
5 Summary(pl.UTF-8):      %{modname} - rozszerzenie ActionScript Message Format
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.9.2
8 Release:        2
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  c5899ca580f19ef7f057b6ea41c2d236
13 URL:            http://pecl.php.net/package/amfext/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Provides:       php(%{modname}) = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Allows to encode and decode PHP data in ActionScript Message Format
23 (AMF) version 0 and 3.
24
25 In PECL status of this extension is: %{status}.
26
27 %description -l pl.UTF-8
28 Rozszerzenie to pozwala (de)kodowanie danych PHP do formatu
29 ActionScript Message Format (AMF) w wersji 0 i 3.
30
31 To rozszerzenie ma w PECL status: %{status}.
32
33 %prep
34 %setup -qc
35 mv %{modname}-%{version}/* .
36
37 %build
38 phpize
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
45 %{__make} install \
46         INSTALL_ROOT=$RPM_BUILD_ROOT \
47         EXTENSION_DIR=%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
49 ; Enable %{modname} extension module
50 extension=%{modname}.so
51 EOF
52
53 mv -f $RPM_BUILD_ROOT%{php_extensiondir}/{amf,%{modname}}.so
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %php_webserver_restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         %php_webserver_restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CREDITS README
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.074891 seconds and 3 git commands to generate.