]> git.pld-linux.org Git - packages/php-pear.git/blob - php-pear.spec
- add Text/CAPTCHA; rel 5
[packages/php-pear.git] / php-pear.spec
1 Summary:        PEAR - PHP Extension and Application Repository
2 Summary(pl.UTF-8):      PEAR - rozszerzenie PHP i repozytorium aplikacji
3 Name:           php-pear
4 Version:        1.3
5 Release:        5
6 Epoch:          4
7 License:        Public Domain
8 Group:          Development/Languages/PHP
9 Source0:        channel-phpunit.xml
10 Source1:        channel-phing.xml
11 Source2:        channel-phpdb.xml
12 Source3:        channel-firephp.xml
13 Source4:        channel-symfony-project.xml
14 Source10:       php-channel-prov.php
15 BuildRequires:  /usr/bin/php
16 BuildRequires:  php-pear-PEAR >= 1:1.9.0
17 BuildRequires:  rpmbuild(macros) >= 1.570
18 Obsoletes:      php-pear-additional_classes
19 Obsoletes:      php4-pear
20 Conflicts:      php-pear-PEAR < 1:1.7.2-10
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         __reg_provides  php %{SOURCE10}
25
26 # find channel provides
27 %define         _use_internal_dependency_generator 0
28 %define         __find_provides %{__reg_provides}
29 %define         __find_requires %{nil}
30
31 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
32 %define         __spec_clean_body       %{nil}
33
34 %description
35 PEAR - PHP Extension and Application Repository.
36
37 Please note that this package provides only basic directory structure.
38 If you want to use base PEAR classes (PEAR.php, PEAR/*.php), that come
39 with PHP, please install appropriate php-pear-* (php-pear-PEAR,
40 php-PEAR-Archive_Tar, etc) packages.
41
42 %description -l pl.UTF-8
43 PEAR (PHP Extension and Application Repository) - rozszerzenie PHP i
44 repozytorium aplikacji.
45
46 Należy pamiętać, że ten pakiet dostarcza tylko podstawową strukturę
47 katalogów. Aby użyć podstawowych klas PEAR (PEAR.php PEAR/*.php),
48 dostarczanych z PHP, należy zainstalować odpowiednie pakiety
49 php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
50
51 %prep
52 %setup -qcT
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{php_pear_dir}/{.registry,bin,data,tests}
57
58 # add extra channels
59 %{__pear} -c pearrc config-set php_dir $RPM_BUILD_ROOT%{php_pear_dir}
60 %{__pear} -c pearrc channel-add %{SOURCE0}
61 %{__pear} -c pearrc channel-add %{SOURCE1}
62 %{__pear} -c pearrc channel-add %{SOURCE2}
63 %{__pear} -c pearrc channel-add %{SOURCE3}
64 %{__pear} -c pearrc channel-add %{SOURCE4}
65
66 while read dir; do
67         install -d $RPM_BUILD_ROOT$dir
68 done <<EOF
69 %{php_pear_dir}/Archive
70 %{php_pear_dir}/Auth
71 %{php_pear_dir}/Cache
72 %{php_pear_dir}/Console
73 %{php_pear_dir}/Contact
74 %{php_pear_dir}/Crypt
75 %{php_pear_dir}/DB/DataObject
76 %{php_pear_dir}/Event
77 %{php_pear_dir}/File
78 %{php_pear_dir}/Genealogy
79 %{php_pear_dir}/Gtk
80 %{php_pear_dir}/Gtk2
81 %{php_pear_dir}/HTML
82 %{php_pear_dir}/HTML/QuickForm
83 %{php_pear_dir}/HTML/Table
84 %{php_pear_dir}/HTML/Template
85 %{php_pear_dir}/HTTP
86 %{php_pear_dir}/HTTP/WebDAV
87 %{php_pear_dir}/HTTP/WebDAV/Tools
88 %{php_pear_dir}/I18N
89 %{php_pear_dir}/Image
90 %{php_pear_dir}/MP3
91 %{php_pear_dir}/Math
92 %{php_pear_dir}/Net
93 %{php_pear_dir}/Net/UserAgent
94 %{php_pear_dir}/Numbers
95 %{php_pear_dir}/PHP
96 %{php_pear_dir}/Payment
97 %{php_pear_dir}/QA
98 %{php_pear_dir}/Science
99 %{php_pear_dir}/Services
100 %{php_pear_dir}/Structures
101 %{php_pear_dir}/Testing
102 %{php_pear_dir}/Text
103 %{php_pear_dir}/Text/CAPTCHA
104 %{php_pear_dir}/Text/Spell
105 %{php_pear_dir}/URI
106 %{php_pear_dir}/Validate
107 %{php_pear_dir}/Validate/Finance
108 %{php_pear_dir}/VersionControl
109 %{php_pear_dir}/XML
110 EOF
111
112 %clean
113 cd $RPM_BUILD_ROOT%{php_pear_dir}
114
115 check_channel_dirs() {
116         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
117         TMPFILE=$(mktemp)
118         find .channels .registry -type d | LC_ALL=C sort > $TMPFILE
119
120         # find finds also '.', so use option -B for diff
121         if rpm -qplv %{_rpmdir}/$RPMFILE | sed -ne '/^d/s,^.*%{php_pear_dir}/\.,.,p' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
122                 rm -rf $RPM_BUILD_ROOT
123         else
124                 echo -e "\nNot so good, some channel directories are not included in package\n"
125                 exit 1
126         fi
127         rm -f $TMPFILE
128 }
129 check_channel_dirs
130
131 %files
132 %defattr(644,root,root,755)
133 %dir %{php_pear_dir}
134 %{php_pear_dir}/*
135
136 %ghost %{php_pear_dir}/.depdblock
137 %ghost %{php_pear_dir}/.depdb
138 %ghost %{php_pear_dir}/.filemap
139 %ghost %{php_pear_dir}/.lock
140
141 %dir %{php_pear_dir}/.registry
142 %dir %{php_pear_dir}/.channels
143 %dir %{php_pear_dir}/.channels/.alias
144
145 # core channels
146 %{php_pear_dir}/.channels/__uri.reg
147 %{php_pear_dir}/.registry/.channel.__uri
148
149 %{php_pear_dir}/.channels/.alias/pear.txt
150 %{php_pear_dir}/.channels/pear.php.net.reg
151
152 %{php_pear_dir}/.channels/.alias/pecl.txt
153 %{php_pear_dir}/.channels/pecl.php.net.reg
154 %{php_pear_dir}/.registry/.channel.pecl.php.net
155
156 %{php_pear_dir}/.channels/.alias/phpdocs.txt
157 %{php_pear_dir}/.channels/doc.php.net.reg
158 %{php_pear_dir}/.registry/.channel.doc.php.net
159
160 # addon channels
161 %{php_pear_dir}/.channels/.alias/phpunit.txt
162 %{php_pear_dir}/.channels/pear.phpunit.de.reg
163 %{php_pear_dir}/.registry/.channel.pear.phpunit.de
164
165 %{php_pear_dir}/.channels/.alias/phing.txt
166 %{php_pear_dir}/.channels/pear.phing.info.reg
167 %{php_pear_dir}/.registry/.channel.pear.phing.info
168
169 %{php_pear_dir}/.channels/.alias/phpdb.txt
170 %{php_pear_dir}/.channels/pear.phpdb.org.reg
171 %{php_pear_dir}/.registry/.channel.pear.phpdb.org
172
173 %{php_pear_dir}/.channels/.alias/firephp.txt
174 %{php_pear_dir}/.channels/pear.firephp.org.reg
175 %{php_pear_dir}/.registry/.channel.pear.firephp.org
176
177 %{php_pear_dir}/.channels/.alias/symfony.txt
178 %{php_pear_dir}/.channels/pear.symfony-project.com.reg
179 %{php_pear_dir}/.registry/.channel.pear.symfony-project.com
This page took 0.072714 seconds and 4 git commands to generate.