]> git.pld-linux.org Git - packages/php-pear.git/blob - php-pear.spec
- release 3
[packages/php-pear.git] / php-pear.spec
1 Summary:        PEAR - PHP Extension and Application Repository
2 Summary(pl.UTF-8):      PEAR - rozszerzenie PHP i repozytorium aplikacji
3 Name:           php-pear
4 Version:        1.3.5
5 Release:        3
6 Epoch:          4
7 License:        Public Domain
8 Group:          Development/Languages/PHP
9 Source0:        php-channel-prov.php
10 Source100:      update-channels.sh
11 Source1:        channel-phing.xml
12 Source2:        channel-phpdb.xml
13 Source3:        channel-firephp.xml
14 Source4:        channel-symfony.xml
15 Source5:        channel-phpunit.xml
16 Source6:        channel-phpseclib.xml
17 Source7:        channel-horde.xml
18 Source8:        channel-rc.xml
19 Source9:        channel-ezc.xml
20 Source10:       channel-propel.xml
21 BuildRequires:  /usr/bin/php
22 BuildRequires:  php-pear-PEAR >= 1:1.9.0
23 BuildRequires:  rpmbuild(macros) >= 1.570
24 Obsoletes:      php-pear-additional_classes
25 Obsoletes:      php4-pear
26 Conflicts:      php-pear-PEAR < 1:1.7.2-10
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         __reg_provides  php %{SOURCE0}
31
32 # find channel provides
33 %define         _use_internal_dependency_generator 0
34 %define         __find_provides %{__reg_provides}
35 %define         __find_requires %{nil}
36
37 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
38 %define         __spec_clean_body       %{nil}
39
40 %description
41 PEAR - PHP Extension and Application Repository.
42
43 Please note that this package provides only basic directory structure.
44 If you want to use base PEAR classes (PEAR.php, PEAR/*.php), that come
45 with PHP, please install appropriate php-pear-* (php-pear-PEAR,
46 php-PEAR-Archive_Tar, etc) packages.
47
48 %description -l pl.UTF-8
49 PEAR (PHP Extension and Application Repository) - rozszerzenie PHP i
50 repozytorium aplikacji.
51
52 Należy pamiętać, że ten pakiet dostarcza tylko podstawową strukturę
53 katalogów. Aby użyć podstawowych klas PEAR (PEAR.php PEAR/*.php),
54 dostarczanych z PHP, należy zainstalować odpowiednie pakiety
55 php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
56
57 %prep
58 %setup -qcT
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{php_pear_dir}/{.registry,bin,data,tests}
63
64 # add extra channels
65 %{__pear} -c pearrc config-set php_dir $RPM_BUILD_ROOT%{php_pear_dir}
66 for xml in $(awk '/^Source[0-9]+:.+channel-.+.xml$/ {print $NF}' %{_specdir}/%{name}.spec); do
67         %{__pear} -c pearrc channel-add %{_sourcedir}/$xml
68 done
69
70 while read dir; do
71         install -d $RPM_BUILD_ROOT$dir
72 done <<EOF
73 %{php_pear_dir}/Archive
74 %{php_pear_dir}/Auth
75 %{php_pear_dir}/Cache
76 %{php_pear_dir}/Console
77 %{php_pear_dir}/Contact
78 %{php_pear_dir}/Crypt
79 %{php_pear_dir}/DB/DataObject
80 %{php_pear_dir}/Event
81 %{php_pear_dir}/File
82 %{php_pear_dir}/Genealogy
83 %{php_pear_dir}/Gtk
84 %{php_pear_dir}/Gtk2
85 %{php_pear_dir}/HTML
86 %{php_pear_dir}/HTML/QuickForm
87 %{php_pear_dir}/HTML/Table
88 %{php_pear_dir}/HTML/Template
89 %{php_pear_dir}/HTTP
90 %{php_pear_dir}/HTTP/WebDAV
91 %{php_pear_dir}/HTTP/WebDAV/Tools
92 %{php_pear_dir}/I18N
93 %{php_pear_dir}/Image
94 %{php_pear_dir}/MP3
95 %{php_pear_dir}/Mail
96 %{php_pear_dir}/Math
97 %{php_pear_dir}/Net
98 %{php_pear_dir}/Net/UserAgent
99 %{php_pear_dir}/Numbers
100 %{php_pear_dir}/PHP
101 %{php_pear_dir}/Payment
102 %{php_pear_dir}/QA
103 %{php_pear_dir}/Science
104 %{php_pear_dir}/Services
105 %{php_pear_dir}/Structures
106 %{php_pear_dir}/Testing
107 %{php_pear_dir}/Text
108 %{php_pear_dir}/Text/CAPTCHA
109 %{php_pear_dir}/Text/Spell
110 %{php_pear_dir}/URI
111 %{php_pear_dir}/Validate
112 %{php_pear_dir}/Validate/Finance
113 %{php_pear_dir}/VersionControl
114 %{php_pear_dir}/XML
115 EOF
116
117 %clean
118 cd $RPM_BUILD_ROOT%{php_pear_dir}
119
120 check_channel_dirs() {
121         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
122         TMPFILE=$(mktemp)
123         find .channels .registry -type d | LC_ALL=C sort > $TMPFILE
124
125         # find finds also '.', so use option -B for diff
126         if rpm -qplv %{_rpmdir}/$RPMFILE | sed -ne '/^d/s,^.*%{php_pear_dir}/\.,.,p' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
127                 rm -rf $RPM_BUILD_ROOT
128         else
129                 echo -e "\nNot so good, some channel directories are not included in package\n"
130                 exit 1
131         fi
132         rm -f $TMPFILE
133 }
134 check_channel_dirs
135
136 %files
137 %defattr(644,root,root,755)
138 %dir %{php_pear_dir}
139 %{php_pear_dir}/*
140
141 %ghost %{php_pear_dir}/.depdblock
142 %ghost %{php_pear_dir}/.depdb
143 %ghost %{php_pear_dir}/.filemap
144 %ghost %{php_pear_dir}/.lock
145
146 %dir %{php_pear_dir}/.registry
147 %dir %{php_pear_dir}/.channels
148 %dir %{php_pear_dir}/.channels/.alias
149
150 # core channels
151 %{php_pear_dir}/.channels/__uri.reg
152 %{php_pear_dir}/.registry/.channel.__uri
153
154 %{php_pear_dir}/.channels/.alias/pear.txt
155 %{php_pear_dir}/.channels/pear.php.net.reg
156
157 %{php_pear_dir}/.channels/.alias/pecl.txt
158 %{php_pear_dir}/.channels/pecl.php.net.reg
159 %{php_pear_dir}/.registry/.channel.pecl.php.net
160
161 %{php_pear_dir}/.channels/.alias/phpdocs.txt
162 %{php_pear_dir}/.channels/doc.php.net.reg
163 %{php_pear_dir}/.registry/.channel.doc.php.net
164
165 # addon channels
166 %{php_pear_dir}/.channels/.alias/phpunit.txt
167 %{php_pear_dir}/.channels/pear.phpunit.de.reg
168 %{php_pear_dir}/.registry/.channel.pear.phpunit.de
169
170 %{php_pear_dir}/.channels/.alias/phing.txt
171 %{php_pear_dir}/.channels/pear.phing.info.reg
172 %{php_pear_dir}/.registry/.channel.pear.phing.info
173
174 %{php_pear_dir}/.channels/.alias/phpdb.txt
175 %{php_pear_dir}/.channels/pear.phpdb.org.reg
176 %{php_pear_dir}/.registry/.channel.pear.phpdb.org
177
178 %{php_pear_dir}/.channels/.alias/firephp.txt
179 %{php_pear_dir}/.channels/pear.firephp.org.reg
180 %{php_pear_dir}/.registry/.channel.pear.firephp.org
181
182 %{php_pear_dir}/.channels/.alias/symfony.txt
183 %{php_pear_dir}/.channels/pear.symfony-project.com.reg
184 %{php_pear_dir}/.registry/.channel.pear.symfony-project.com
185
186 %{php_pear_dir}/.channels/.alias/phpseclib.txt
187 %{php_pear_dir}/.channels/phpseclib.sourceforge.net.reg
188 %{php_pear_dir}/.registry/.channel.phpseclib.sourceforge.net
189
190 %{php_pear_dir}/.channels/.alias/horde.txt
191 %{php_pear_dir}/.channels/pear.horde.org.reg
192 %{php_pear_dir}/.registry/.channel.pear.horde.org
193
194 %{php_pear_dir}/.channels/.alias/rc.txt
195 %{php_pear_dir}/.channels/pear.roundcube.net.reg
196 %{php_pear_dir}/.registry/.channel.pear.roundcube.net
197
198 %{php_pear_dir}/.channels/.alias/ezc.txt
199 %{php_pear_dir}/.channels/components.ez.no.reg
200 %{php_pear_dir}/.registry/.channel.components.ez.no
201
202 %{php_pear_dir}/.channels/.alias/propel.txt
203 %{php_pear_dir}/.channels/pear.propelorm.org.reg
204 %{php_pear_dir}/.registry/.channel.pear.propelorm.org
This page took 0.03869 seconds and 4 git commands to generate.