]> git.pld-linux.org Git - packages/php-pear.git/blob - php-pear.spec
- PEAR dir owned by PEAR itself; rel 12
[packages/php-pear.git] / php-pear.spec
1 Summary:        PEAR - PHP Extension and Application Repository
2 Summary(pl):    PEAR - rozszerzenie PHP i repozytorium aplikacji
3 Name:           php-pear
4 Version:        1.0
5 Release:        12
6 Epoch:          4
7 License:        Public Domain
8 Group:          Development/Languages/PHP
9 Obsoletes:      php-pear-additional_classes
10 Obsoletes:      php4-pear
11 Provides:       php4-pear = %{epoch}:%{version}-%{release}
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 PEAR - PHP Extension and Application Repository.
17
18 Please note that this package provides only basic directory structure.
19 If you want to use base PEAR classes (PEAR.php, PEAR/*.php), that come
20 with PHP, please install appropriate php-pear-* (php-pear-PEAR,
21 php-PEAR-Archive_Tar, etc) packages.
22
23 %description -l pl
24 PEAR (PHP Extension and Application Repository) - rozszerzenie PHP i
25 repozytorium aplikacji.
26
27 Nale¿y pamiêtaæ, ¿e ten pakiet dostarcza tylko podstawow± strukturê
28 katalogów. Aby u¿yæ podstawowych klas PEAR (PEAR.php PEAR/*.php),
29 dostarczanych z PHP, nale¿y zainstalowaæ odpowiednie pakiety
30 php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
31
32 %prep
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{php_pear_dir}/{data,tests}
37
38 while read dir; do
39         install -d $RPM_BUILD_ROOT$dir
40 done <<EOF
41 %{php_pear_dir}/Archive
42 %{php_pear_dir}/Auth
43 %{php_pear_dir}/Console
44 %{php_pear_dir}/Crypt
45 %{php_pear_dir}/Contact
46 %{php_pear_dir}/DB/DataObject
47 %{php_pear_dir}/Gtk
48 %{php_pear_dir}/HTML
49 %{php_pear_dir}/HTML/Template
50 %{php_pear_dir}/HTML/Table
51 %{php_pear_dir}/HTML/QuickForm
52 %{php_pear_dir}/HTTP
53 %{php_pear_dir}/HTTP/WebDAV
54 %{php_pear_dir}/HTTP/WebDAV/Tools
55 %{php_pear_dir}/Image
56 %{php_pear_dir}/Math
57 %{php_pear_dir}/MP3
58 %{php_pear_dir}/Net
59 %{php_pear_dir}/Numbers
60 %{php_pear_dir}/Payment
61 %{php_pear_dir}/PHP
62 %{php_pear_dir}/Science
63 %{php_pear_dir}/Services
64 %{php_pear_dir}/Structures
65 %{php_pear_dir}/Text
66 %{php_pear_dir}/XML
67 %{php_pear_dir}/Validate
68 %{php_pear_dir}/Validate/Finance
69 EOF
70
71 # registry
72 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{php_pear_dir}/.registry}
73 > $RPM_BUILD_ROOT%{php_pear_dir}/.filemap
74 > $RPM_BUILD_ROOT%{php_pear_dir}/.lock
75
76 %post
77 umask 002
78 if [ ! -e %{php_pear_dir}/.filemap ]; then
79         touch %{php_pear_dir}/.filemap
80 fi
81 if [ ! -e %{php_pear_dir}/.lock ]; then
82         touch %{php_pear_dir}/.lock
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %dir %{php_pear_dir}
88 # LANG=C is in 'prep', so this should work in locales like et_EE where [a-z] does not specify whole alphabet
89 %{php_pear_dir}/[A-Z]*
90
91 # see 'pear config-show'
92 %dir %{php_pear_dir}/data
93 %dir %{php_pear_dir}/tests
94
95 # registry
96 %dir %{php_pear_dir}/.registry
97 %ghost %{php_pear_dir}/.filemap
98 %ghost %{php_pear_dir}/.lock
This page took 0.047846 seconds and 3 git commands to generate.