]> git.pld-linux.org Git - packages/php-pear.git/blob - php-pear.spec
- from http://pear.symfony-project.com/channel.xml
[packages/php-pear.git] / php-pear.spec
1 Summary:        PEAR - PHP Extension and Application Repository
2 Summary(pl.UTF-8):      PEAR - rozszerzenie PHP i repozytorium aplikacji
3 Name:           php-pear
4 Version:        1.2
5 Release:        2
6 Epoch:          4
7 License:        Public Domain
8 Group:          Development/Languages/PHP
9 Source0:        channel-phpunit.xml
10 Source1:        channel-phing.xml
11 Source2:        channel-phpdb.xml
12 Source3:        channel-firephp.xml
13 Source10:       php-channel-prov.php
14 BuildRequires:  /usr/bin/php
15 BuildRequires:  php-pear-PEAR
16 Obsoletes:      php-pear-additional_classes
17 Obsoletes:      php4-pear
18 Conflicts:      php-pear-PEAR < 1:1.7.2-10
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         __reg_provides  php %{SOURCE10}
23
24 # find channel provides
25 %define         _use_internal_dependency_generator 0
26 %define         __find_provides %{__reg_provides}
27 %define         __find_requires %{nil}
28
29 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
30 %define         __spec_clean_body       %{nil}
31
32 %description
33 PEAR - PHP Extension and Application Repository.
34
35 Please note that this package provides only basic directory structure.
36 If you want to use base PEAR classes (PEAR.php, PEAR/*.php), that come
37 with PHP, please install appropriate php-pear-* (php-pear-PEAR,
38 php-PEAR-Archive_Tar, etc) packages.
39
40 %description -l pl.UTF-8
41 PEAR (PHP Extension and Application Repository) - rozszerzenie PHP i
42 repozytorium aplikacji.
43
44 Należy pamiętać, że ten pakiet dostarcza tylko podstawową strukturę
45 katalogów. Aby użyć podstawowych klas PEAR (PEAR.php PEAR/*.php),
46 dostarczanych z PHP, należy zainstalować odpowiednie pakiety
47 php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
48
49 %prep
50 %setup -qcT
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{php_pear_dir}/{bin,data,tests}
55
56 # add extra channels
57 pear -c pearrc config-set php_dir $RPM_BUILD_ROOT%{php_pear_dir}
58 pear -c pearrc channel-add %{SOURCE0}
59 pear -c pearrc channel-add %{SOURCE1}
60 pear -c pearrc channel-add %{SOURCE2}
61 pear -c pearrc channel-add %{SOURCE3}
62
63 while read dir; do
64         install -d $RPM_BUILD_ROOT$dir
65 done <<EOF
66 %{php_pear_dir}/.registry
67 %{php_pear_dir}/bin
68 %{php_pear_dir}/Archive
69 %{php_pear_dir}/Auth
70 %{php_pear_dir}/Cache
71 %{php_pear_dir}/Console
72 %{php_pear_dir}/Contact
73 %{php_pear_dir}/Crypt
74 %{php_pear_dir}/DB/DataObject
75 %{php_pear_dir}/Event
76 %{php_pear_dir}/File
77 %{php_pear_dir}/Genealogy
78 %{php_pear_dir}/Gtk
79 %{php_pear_dir}/Gtk2
80 %{php_pear_dir}/HTML
81 %{php_pear_dir}/HTML/QuickForm
82 %{php_pear_dir}/HTML/Table
83 %{php_pear_dir}/HTML/Template
84 %{php_pear_dir}/HTTP
85 %{php_pear_dir}/HTTP/WebDAV
86 %{php_pear_dir}/HTTP/WebDAV/Tools
87 %{php_pear_dir}/I18N
88 %{php_pear_dir}/Image
89 %{php_pear_dir}/MP3
90 %{php_pear_dir}/Math
91 %{php_pear_dir}/Net
92 %{php_pear_dir}/Numbers
93 %{php_pear_dir}/PHP
94 %{php_pear_dir}/Payment
95 %{php_pear_dir}/QA
96 %{php_pear_dir}/Science
97 %{php_pear_dir}/Services
98 %{php_pear_dir}/Structures
99 %{php_pear_dir}/Testing
100 %{php_pear_dir}/Text
101 %{php_pear_dir}/Text/Spell
102 %{php_pear_dir}/URI
103 %{php_pear_dir}/Validate
104 %{php_pear_dir}/Validate/Finance
105 %{php_pear_dir}/VersionControl
106 %{php_pear_dir}/XML
107 EOF
108
109 %clean
110 cd $RPM_BUILD_ROOT%{php_pear_dir}
111
112 check_channel_dirs() {
113         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
114         TMPFILE=$(mktemp)
115         find .channels .registry -type d | LC_ALL=C sort > $TMPFILE
116
117         # find finds also '.', so use option -B for diff
118         if rpm -qplv %{_rpmdir}/$RPMFILE | sed -ne '/^d/s,^.*%{php_pear_dir}/\.,.,p' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
119                 rm -rf $RPM_BUILD_ROOT
120         else
121                 echo -e "\nNot so good, some channel directories are not included in package\n"
122                 exit 1
123         fi
124         rm -f $TMPFILE
125 }
126 check_channel_dirs
127
128 %files
129 %defattr(644,root,root,755)
130 %dir %{php_pear_dir}
131 %{php_pear_dir}/*
132
133 %ghost %{php_pear_dir}/.depdblock
134 %ghost %{php_pear_dir}/.depdb
135 %ghost %{php_pear_dir}/.filemap
136 %ghost %{php_pear_dir}/.lock
137
138 %dir %{php_pear_dir}/.registry
139 %dir %{php_pear_dir}/.channels
140 %dir %{php_pear_dir}/.channels/.alias
141
142 %{php_pear_dir}/.channels/__uri.reg
143 %{php_pear_dir}/.registry/.channel.__uri
144
145 %{php_pear_dir}/.channels/.alias/pear.txt
146 %{php_pear_dir}/.channels/pear.php.net.reg
147
148 %{php_pear_dir}/.channels/.alias/pecl.txt
149 %{php_pear_dir}/.channels/pecl.php.net.reg
150 %{php_pear_dir}/.registry/.channel.pecl.php.net
151
152 %{php_pear_dir}/.channels/.alias/phpunit.txt
153 %{php_pear_dir}/.channels/pear.phpunit.de.reg
154 %{php_pear_dir}/.registry/.channel.pear.phpunit.de
155
156 %{php_pear_dir}/.channels/.alias/phing.txt
157 %{php_pear_dir}/.channels/pear.phing.info.reg
158 %{php_pear_dir}/.registry/.channel.pear.phing.info
159
160 %{php_pear_dir}/.channels/.alias/phpdb.txt
161 %{php_pear_dir}/.channels/pear.phpdb.org.reg
162 %{php_pear_dir}/.registry/.channel.pear.phpdb.org
163
164 %{php_pear_dir}/.channels/.alias/firephp.txt
165 %{php_pear_dir}/.channels/pear.firephp.org.reg
166 %{php_pear_dir}/.registry/.channel.pear.firephp.org
This page took 0.0698260000000001 seconds and 3 git commands to generate.