]> git.pld-linux.org Git - packages/php-pear-XML_XPath.git/blob - php-pear-XML_XPath.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/php-pear-XML_XPath.git] / php-pear-XML_XPath.spec
1 %define         _class          XML
2 %define         _subclass       XPath
3 %define         _status         stable
4 %define         _pearname       %{_class}_%{_subclass}
5 Summary:        %{_pearname} - XPath/DOM XML manipulation, maneuvering and query interface
6 Summary(pl.UTF-8):      %{_pearname} - interfejs do obróbki i zapytań XPath/DOM XML
7 Name:           php-pear-%{_pearname}
8 Version:        1.2.4
9 Release:        3
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
13 # Source0-md5:  b0af5c50625373a13400db23b85b4924
14 Patch0:         %{name}-path_fix.patch
15 URL:            http://pear.php.net/package/XML_XPath/
16 BuildRequires:  php-pear-PEAR
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
18 BuildRequires:  rpmbuild(macros) >= 1.300
19 Requires:       php-common < 3:5.0.0
20 Requires:       php-common >= 3:4.2.1
21 Requires:       php-domxml
22 Requires:       php-pear
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The PEAR::XML_XPath class provides an XPath/DOM XML manipulation,
28 maneuvering and query interface.
29
30 The class allows for easy manipulation, maneuvering and querying of a
31 DOMXML tree using both XPath queries and DOM walk functions. It uses
32 an internal pointer for all methods on which the action is performed.
33 Results from an DOM/XPath query are returned as an XPath_Result
34 object, which contains an internal array of DOM nodes and which
35 extends the common DOM class and hence contains all the DOM functions
36 from the main object to run on each of the elements in the internal
37 array. This class tries to hold as close as possible to the DOM
38 Recommendation. You MUST have the domxml extension to use this class.
39
40 The XML_XPath class was inspired by a class maintained by Nigel
41 Swinson called phpxpath. The phpxpath class does not rely on PHP
42 xmldom functions and is therefore a sibling to this class:
43 <http://sourceforge.net/projects/phpxpath/>.
44
45 In PEAR status of this package is: %{_status}.
46
47 %description -l pl.UTF-8
48 Klasa PEAR::XML_XPath udostępnia interfejs do obróbki, manewrowania i
49 zapytań XPath/DOM XML.
50
51 Klasa ta pozwala na łatwe manipulowanie, manewrowanie i odpytywanie
52 drzewa DOMXML przy użyciu zapytań XPath i funkcji chodzących DOM.
53 Używa wewnętrznego wskaźnika dla wszystkich metod, na których jest
54 wykonywana akcja. Wyniki zapytań DOM/XPath są zwracane jako obiekt
55 XPath_Result, który zawiera wewnętrzną tablicę węzłów DOM i rozszerza
56 ogólną klasę DOM, przez co zawiera wszystkie funkcje DOM z głównego
57 obiektu, które można uruchamiać na każdym z elementów wewnętrznej
58 tablicy. Ta klasa próbuje być najbliżej rekomendacji DOM na ile to
59 możliwe. Aby używać tej klasy, trzeba mieć rozszerzenie domxml.
60
61 Klasa XML_XPath była inspirowana klasą phpxpath utrzymywaną przez
62 Nigela Swinsona. Klasa phpxpath nie polega na funkcjach PHP xmldom,
63 dlatego jest siostrzana dla tej klasy:
64 <http://sourceforge.net/projects/phpxpath/>.
65
66 Ta klasa ma w PEAR status: %{_status}.
67
68 %prep
69 %pear_package_setup
70 cd ./%{php_pear_dir}/%{_class}
71 %patch0 -p2
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{php_pear_dir}
76 %pear_package_install
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc install.log
84 %doc docs/%{_pearname}/docs/*
85 %dir %{php_pear_dir}/%{_class}/%{_subclass}
86 %{php_pear_dir}/.registry/*.reg
87 %{php_pear_dir}/%{_class}/*.php
88 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.039829 seconds and 4 git commands to generate.