]> git.pld-linux.org Git - packages/php-pear-XML_XPath.git/blob - php-pear-XML_XPath.spec
- do not use macros in URL
[packages/php-pear-XML_XPath.git] / php-pear-XML_XPath.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          XML
3 %define         _subclass       XPath
4 %define         _status         beta
5 %define         _pearname       %{_class}_%{_subclass}
6 Summary:        %{_pearname} - XPath/DOM XML manipulation, maneuvering and query interface
7 Summary(pl):    %{_pearname} - interfejs do obróbki i zapytañ XPath/DOM XML
8 Name:           php-pear-%{_pearname}
9 Version:        1.2
10 Release:        1
11 License:        PHP 2.02
12 Group:          Development/Languages/PHP
13 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
14 # Source0-md5:  71362e0ef17bfd56c63c3955d5ce91b8
15 URL:            http://pear.php.net/package/XML_XPath/
16 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
17 Requires:       php-pear
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The PEAR::XML_XPath class provides an XPath/DOM XML manipulation,
23 maneuvering and query interface.
24
25 The class allows for easy manipulation, maneuvering and querying of a
26 DOMXML tree using both XPath queries and DOM walk functions. It uses
27 an internal pointer for all methods on which the action is performed.
28 Results from an DOM/XPath query are returned as an XPath_Result
29 object, which contains an internal array of DOM nodes and which
30 extends the common DOM class and hence contains all the DOM functions
31 from the main object to run on each of the elements in the internal
32 array. This class tries to hold as close as possible to the DOM
33 Recommendation. You MUST have the domxml extension to use this class.
34
35 The XML_XPath class was inspired by a class maintained by Nigel
36 Swinson called phpxpath. The phpxpath class does not rely on PHP
37 xmldom functions and is therefore a sibling to this class:
38 http://sourceforge.net/projects/phpxpath/.
39
40 This class has in PEAR status: %{_status}.
41
42 %description -l pl
43 Klasa PEAR::XML_XPath udostêpnia interfejs do obróbki, manewrowania i
44 zapytañ XPath/DOM XML.
45
46 Klasa ta pozwala na ³atwe manipulowanie, manewrowanie i odpytywanie
47 drzewa DOMXML przy u¿yciu zapytañ XPath i funkcji chodz±cych DOM.
48 U¿ywa wewnêtrznego wska¼nika dla wszystkich metod, na których jest
49 wykonywana akcja. Wyniki zapytañ DOM/XPath s± zwracane jako obiekt
50 XPath_Result, który zawiera wewnêtrzn± tablicê wêz³ów DOM i rozszerza
51 ogóln± klasê DOM, przez co zawiera wszystkie funkcje DOM z g³ównego
52 obiektu, które mo¿na uruchamiaæ na ka¿dym z elementów wewnêtrznej
53 tablicy. Ta klasa próbuje byæ najbli¿ej rekomendacji DOM na ile to
54 mo¿liwe. Aby u¿ywaæ tej klasy, trzeba mieæ rozszerzenie domxml.
55
56 Klasa XML_XPath by³a inspirowana klas± phpxpath utrzymywan± przez
57 Nigela Swinsona. Klasa phpxpath nie polega na funkcjach PHP xmldom,
58 dlatego jest siostrzana dla tej klasy:
59 http://sourceforge.net/projects/phpxpath/.
60
61 Ta klasa ma w PEAR status: %{_status}.
62
63 %prep
64 %setup -q -c
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/{,%{_subclass}}
69
70 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
71 install %{_pearname}-%{version}/%{_subclass}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc %{_pearname}-%{version}/docs/*
79 %dir %{php_pear_dir}/%{_class}/%{_subclass}
80 %{php_pear_dir}/%{_class}/*.php
81 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.067577 seconds and 4 git commands to generate.