]> git.pld-linux.org Git - packages/php-pear-XML_XPath.git/blob - php-pear-XML_XPath.spec
- massive cosmetics
[packages/php-pear-XML_XPath.git] / php-pear-XML_XPath.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          XML
3 %define         _subclass       XPath
4 %define         _status         devel
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - XPath/DOM XML manipulation, maneuvering and query interface
8 Summary(pl):    %{_pearname} - interfejs do obróbki i zapytañ XPath/DOM XML
9 Name:           php-pear-%{_pearname}
10 Version:        1.2.1
11 Release:        1
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  916f60741d5db46b190512e1ba72964c
16 URL:            http://pear.php.net/package/XML_XPath/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The PEAR::XML_XPath class provides an XPath/DOM XML manipulation,
24 maneuvering and query interface.
25
26 The class allows for easy manipulation, maneuvering and querying of a
27 DOMXML tree using both XPath queries and DOM walk functions. It uses
28 an internal pointer for all methods on which the action is performed.
29 Results from an DOM/XPath query are returned as an XPath_Result
30 object, which contains an internal array of DOM nodes and which
31 extends the common DOM class and hence contains all the DOM functions
32 from the main object to run on each of the elements in the internal
33 array. This class tries to hold as close as possible to the DOM
34 Recommendation. You MUST have the domxml extension to use this class.
35
36 The XML_XPath class was inspired by a class maintained by Nigel
37 Swinson called phpxpath. The phpxpath class does not rely on PHP
38 xmldom functions and is therefore a sibling to this class:
39 http://sourceforge.net/projects/phpxpath/.
40
41 This class has in PEAR status: %{_status}.
42
43 %description -l pl
44 Klasa PEAR::XML_XPath udostêpnia interfejs do obróbki, manewrowania i
45 zapytañ XPath/DOM XML.
46
47 Klasa ta pozwala na ³atwe manipulowanie, manewrowanie i odpytywanie
48 drzewa DOMXML przy u¿yciu zapytañ XPath i funkcji chodz±cych DOM.
49 U¿ywa wewnêtrznego wska¼nika dla wszystkich metod, na których jest
50 wykonywana akcja. Wyniki zapytañ DOM/XPath s± zwracane jako obiekt
51 XPath_Result, który zawiera wewnêtrzn± tablicê wêz³ów DOM i rozszerza
52 ogóln± klasê DOM, przez co zawiera wszystkie funkcje DOM z g³ównego
53 obiektu, które mo¿na uruchamiaæ na ka¿dym z elementów wewnêtrznej
54 tablicy. Ta klasa próbuje byæ najbli¿ej rekomendacji DOM na ile to
55 mo¿liwe. Aby u¿ywaæ tej klasy, trzeba mieæ rozszerzenie domxml.
56
57 Klasa XML_XPath by³a inspirowana klas± phpxpath utrzymywan± przez
58 Nigela Swinsona. Klasa phpxpath nie polega na funkcjach PHP xmldom,
59 dlatego jest siostrzana dla tej klasy:
60 http://sourceforge.net/projects/phpxpath/.
61
62 Ta klasa ma w PEAR status: %{_status}.
63
64 %prep
65 %setup -q -c
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/{,%{_subclass}}
70
71 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
72 install %{_pearname}-%{version}/%{_subclass}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc %{_pearname}-%{version}/docs/*
80 %dir %{php_pear_dir}/%{_class}/%{_subclass}
81 %{php_pear_dir}/%{_class}/*.php
82 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.074613 seconds and 4 git commands to generate.