]> git.pld-linux.org Git - packages/php-pear-XML_SaxFilters.git/blob - php-pear-XML_SaxFilters.spec
- spelling fixes, uppercases, etc.
[packages/php-pear-XML_SaxFilters.git] / php-pear-XML_SaxFilters.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          XML
3 %define         _subclass       SaxFilters
4 %define         _status         beta
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - a framework for building XML filters using the SAX API
8 Summary(pl):    %{_pearname} - tworzenie filtrów XML za pomoc± API SAX
9 Name:           php-pear-%{_pearname}
10 Version:        0.3.0
11 Release:        1
12 License:        PHP
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  205e7ab8b5fcc63e131ad6c96f7aa09c
16 URL:            http://pear.php.net/package/XML_SaxFilters/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 XML_SaxFilters provides a foundation for using Sax filters in PHP. The
24 original code base was developed by Luis Argerich and published at
25 http://phpxmlclasses.sourceforge.net/show_doc.php?class=class_sax_filters.html.
26 Luis discussed how SaxFilters work, using the Sourceforge classes as
27 an example, in Chapter 10 of Wrox "PHP 4 XML". Luis kindly gave
28 permission to modify the code and license for inclusion in PEAR.
29
30 This version of the Sax Filters makes significant changes to Luis's
31 original code (backwards compatibility is definately broken),
32 seperating abstract classes from interfaces, providing interfaces for
33 data readers and writers and providing methods to help parse XML
34 documents recursively with filters (for example
35 AbstractFilter::setParent()) for documents where the structure can
36 vary significantly.
37
38 Sax Filtering is an approach to making parsing XML documents with Sax
39 modular and easy to maintain. The parser delegates events to a child
40 filter which may in turn delegate events to another filter. In general
41 it's possible to implement filters for a document which are as
42 flexible and powerful as DOM.
43
44 In PEAR status of this package is: %{_status}.
45
46 %description -l pl
47 XML_SaxFilters dostarcza podstawy do u¿ycia filtrów Sax w PHP.
48 Originalny kod zosta³ opracowany przez Luisa Argericha i opublikowany
49 pod adresem
50 http://phpxmlclasses.sourceforge.net/show_doc.php?class=class_sax_filters.html.
51 Luis podda³ dyskusji sposób, w jaki dzia³aj± SaxFilters, u¿ywaj±c jako
52 przyk³adu klas Sourceforge, w rozdziale 10 "PHP 4 XML" wydawnictwa
53 Wrox. Luis zezwoli³ na modyfikacjê kodu i licencji tak, aby klasa ta
54 mog³a zostaæ do³±czona do PEAR.
55
56 Ta wersja Filtrów Sax wprowadza znacz±ce zmiany w stosunku do
57 oryginalnego kodu Luisa (wsteczna zgodno¶æ nie zosta³a zachowana),
58 oddzielaj±c abstrakcyjne klasy od interfejsu, dostarczaj±c interfejsy
59 do odczytu i zapisu danych oraz metody wspomagaj±ce rekursywne
60 parsowanie dokumentów XML (na przyk³ad AbstractFilter::setParent())
61 dla dokumentów, których struktura mo¿e siê znacz±co ró¿niæ.
62
63 Celem filtrowania Sax jest sprawienie, i¿ parsowanie dokumetnów bêdzie
64 modularne i ³atwe do zarz±dzania. Parser wysy³a zdarzenia to filtra
65 dziecka, które z kolei mo¿e wys³aæ zdarzenia do innego filtra. Mo¿liwe
66 jest zaimplementowanie filtrów, które bêd± tak elastyczne i potê¿ne
67 jak DOM.
68
69 Ta klasa ma w PEAR status: %{_status}.
70
71 %prep
72 %setup -q -c
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/IO
77
78 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
79 install %{_pearname}-%{version}/%{_subclass}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
80 install %{_pearname}-%{version}/%{_subclass}/IO/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/IO
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc %{_pearname}-%{version}/docs/*
88 %{php_pear_dir}/%{_class}/*.php
89 %{php_pear_dir}/%{_class}/%{_subclass}
This page took 0.081434 seconds and 4 git commands to generate.