]> git.pld-linux.org Git - packages/php-pear-XML_HTMLSax.git/blob - php-pear-XML_HTMLSax.spec
eff61bffeeb28a10699341ba07ac634784a51f01
[packages/php-pear-XML_HTMLSax.git] / php-pear-XML_HTMLSax.spec
1 # ToDo:
2 # - pl summary/description
3 %include        /usr/lib/rpm/macros.php
4 %define         _class          XML
5 %define         _subclass       HTMLSax
6 %define         _status         stable
7 %define         _pearname       %{_class}_%{_subclass}
8 Summary:        %{_pearname} - A SAX based parser for HTML and other badly formed XML documents
9 Name:           php-pear-%{_pearname}
10 Version:        1.0
11 Release:        1
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  795b38020a9984440f57312b0c80b438
16 URL:            http://pear.php.net/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 XML_HTMLSax is a SAX based XML parser for badly formed XML documents,
24 such as HTML. The original code base was developed by Alexander Zhukov
25 and published at http://sourceforge.net/projects/phpshelve/, who in
26 turn was inspired by the Python HTMLSax package. Alexander kindly gave
27 permission to modify the code and license for inclusion in PEAR.
28 PEAR::XML_HTMLSax takes the last release from Sourceforge
29 (HTMLSax2002082201) and changes the API to make using HTMLSax very
30 similar to using the native PHP Expat extension, opening it up for use
31 with projects like SAX filters:
32 http://phpxmlclasses.sourceforge.net/show_doc.php?class=class_sax_filters.html.
33 This version also fixes some bugs and adds further features such as
34 the ability to handle processing instructions and JSP/ASP markup.
35
36 This class has in PEAR status: %{_status}.
37
38 %prep
39 %setup -q -c
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
44
45 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc %{_pearname}-%{version}/docs
53 %{php_pear_dir}/%{_class}/*.php
This page took 0.022823 seconds and 3 git commands to generate.