]> git.pld-linux.org Git - packages/php-pear-PHP_UML.git/blob - php-pear-PHP_UML.spec
- updated to 0.5.1
[packages/php-pear-PHP_UML.git] / php-pear-PHP_UML.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PHP
3 %define         _subclass       UML
4 %define         _status         beta
5 %define         _pearname       PHP_UML
6 Summary:        %{_pearname} - produce an UML/XMI representation of the classes and packages found on system
7 Summary(pl.UTF-8):      %{_pearname} - tworzenie struktury UML/XMI klas i pakietów znalezionych w systemie
8 Name:           php-pear-%{_pearname}
9 Version:        0.5.1
10 Release:        1
11 License:        LGPL
12 Group:          Development/Languages/PHP
13 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
14 # Source0-md5:  15507c3d92345946cc76e69adf889e24
15 URL:            http://pear.php.net/package/PHP_UML/
16 BuildRequires:  php-pear-PEAR
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 PHP_UML is a PHP parser, an XMI generator, as well as a
24 metamodel-driven application. Practically, with PHP_UML, you can feed
25 an UML CASE tool, like Rational Rose or Argouml, with an UML
26 representation of existing PHP source code. This way, you get an
27 instant overview of a given application, with all the usual functions
28 of a software design tool, like class diagrams exportation,
29 refactoring of object-oriented applications, or automatic code
30 generation.
31
32 PHP_UML:
33  - Parses classes, interfaces, inheritance and implementation
34    relations,
35  - Parses properties, class constants, visibility and static
36    attributes,
37  - Parses functions, their parameters, their default values, their
38    types (when stated),
39  - Parses docblock comments : class comments (@package), function
40    comments (@param and @return) and header file comments (@package),
41  - Interprets the PHP namespacing instructions ("namespace" and "use"),
42  - Does automatic type detection, through the default values,
43  - Generates UML in version 1.4, and version 2.1,
44  - Generates logical, component, and deployment views,
45
46 Other UML elements will be available in future releases.
47
48 In PEAR status of this package is: %{_status}.
49
50 %description -l pl.UTF-8
51 PHP_UML to parser PHP, generator XML jak również aplikacja wzorowana
52 na meta-model. Praktycznie rzecz biorąc, za pomocą PHP_UML możliwe
53 jest przekazanie narzędziom UML CASE, takim jak Rational Rose czy
54 Argouml, schematu UML kodu PHP. W ten sposób możliwe jest
55 natychmiastowy podgląd aplikacji, ze wszystkimi funkcjami narzędzi do
56 projektowania aplikacjia, takimi jak eksportem diagramów funkcji,
57 refaktoryzacji zorientowanych obiektowo aplikacji, czy automatycznego
58 generowania kodu.
59
60 PHP_UML:
61  - przetwarzanie relacji klas, interfejsów, dziedziczenia i
62    implementacji,
63  - przetwarzanie właściwości, stałych, widoczności i stałych atrybutów
64    klas,
65  - przetwarzanie funkcji, ich parametrów, zwracanych funkcji i typów
66    (jeśli określone),
67  - przetwarzanie komentarzy docblook : komentarzy klas (@package),
68    funkcji (@param i @return) i nagłówków plików (@package),
69  - interpretacja instrukcji przestrzeni nazw PHP ("namespace" i "use"),
70  - autoamtyczna detekcja typu z pomocą domyślnych wartości,
71  - generowania UML w wersji 1.4 i 2.1
72  - generowanie widoków logicznych, komponentów.
73
74 Ta klasa ma w PEAR status: %{_status}.
75
76 %package tests
77 Summary:        Tests for PEAR::%{_pearname}
78 Summary(pl.UTF-8):      Testy dla PEAR::%{_pearname}
79 Group:          Development/Languages/PHP
80 AutoReq:        no
81 Requires:       %{name} = %{version}-%{release}
82 AutoProv:       no
83
84 %description tests
85 Tests for PEAR::%{_pearname}.
86
87 %description tests -l pl.UTF-8
88 Testy dla PEAR::%{_pearname}.
89
90 %prep
91 %pear_package_setup
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{php_pear_dir}
96 %pear_package_install
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc install.log docs/PHP_UML/{docs,examples}
104 %{php_pear_dir}/.registry/*.reg
105 %{php_pear_dir}/PHP/UML
106 %{php_pear_dir}/PHP/UML.php
107
108 %files tests
109 %defattr(644,root,root,755)
110 %{php_pear_dir}/tests/PHP_UML
This page took 0.071362 seconds and 4 git commands to generate.