]> git.pld-linux.org Git - packages/php-pear-PHP_UML.git/blob - php-pear-PHP_UML.spec
- updated to: 1.6.0
[packages/php-pear-PHP_UML.git] / php-pear-PHP_UML.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _status         stable
3 %define         _pearname       PHP_UML
4 Summary:        %{_pearname} - produce an UML/XMI representation of the classes and packages found on system
5 Summary(pl.UTF-8):      %{_pearname} - tworzenie struktury UML/XMI klas i pakietów znalezionych w systemie
6 Name:           php-pear-%{_pearname}
7 Version:        1.6.0
8 Release:        1
9 License:        LGPL
10 Group:          Development/Languages/PHP
11 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
12 # Source0-md5:  a200a5f716527dd2bd75f4a988417841
13 URL:            http://pear.php.net/package/PHP_UML/
14 BuildRequires:  php-pear-PEAR >= 1:1.4.0
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.300
17 Requires:       php-pear
18 Requires:       php-pear-Console_CommandLine
19 Requires:       php-spl
20 Requires:       php-xsl
21 Obsoletes:      php-pear-PHP_UML-tests
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 PHP_UML is a PHP parser, an XMI generator, as well as a
27 metamodel-driven application. Practically, with PHP_UML, you can feed
28 an UML CASE tool, like Rational Rose or Argouml, with an UML
29 representation of existing PHP source code. This way, you get an
30 instant overview of a given application, with all the usual functions
31 of a software design tool, like class diagrams exportation,
32 refactoring of object-oriented applications, or automatic code
33 generation.
34
35 PHP_UML:
36  - Parses classes, interfaces, inheritance and implementation
37    relations,
38  - Parses properties, class constants, visibility and static
39    attributes,
40  - Parses functions, their parameters, their default values, their
41    types (when stated),
42  - Parses docblock comments : class comments (@package), function
43    comments (@param and @return) and header file comments (@package),
44  - Interprets the PHP namespacing instructions ("namespace" and "use"),
45  - Does automatic type detection, through the default values,
46  - Generates UML in version 1.4, and version 2.1,
47  - Generates logical, component, and deployment views,
48
49 Other UML elements will be available in future releases.
50
51 In PEAR status of this package is: %{_status}.
52
53 %description -l pl.UTF-8
54 PHP_UML to parser PHP, generator XML jak również aplikacja wzorowana
55 na meta-model. Praktycznie rzecz biorąc, za pomocą PHP_UML możliwe
56 jest przekazanie narzędziom UML CASE, takim jak Rational Rose czy
57 Argouml, schematu UML kodu PHP. W ten sposób możliwe jest
58 natychmiastowy podgląd aplikacji, ze wszystkimi funkcjami narzędzi do
59 projektowania aplikacjia, takimi jak eksportem diagramów funkcji,
60 refaktoryzacji zorientowanych obiektowo aplikacji, czy automatycznego
61 generowania kodu.
62
63 PHP_UML:
64  - przetwarzanie relacji klas, interfejsów, dziedziczenia i
65    implementacji,
66  - przetwarzanie właściwości, stałych, widoczności i stałych atrybutów
67    klas,
68  - przetwarzanie funkcji, ich parametrów, zwracanych funkcji i typów
69    (jeśli określone),
70  - przetwarzanie komentarzy docblook : komentarzy klas (@package),
71    funkcji (@param i @return) i nagłówków plików (@package),
72  - interpretacja instrukcji przestrzeni nazw PHP ("namespace" i "use"),
73  - autoamtyczna detekcja typu z pomocą domyślnych wartości,
74  - generowania UML w wersji 1.4 i 2.1
75  - generowanie widoków logicznych, komponentów.
76
77 Ta klasa ma w PEAR status: %{_status}.
78
79 %prep
80 %pear_package_setup
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{php_pear_dir}
85 %pear_package_install
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc install.log docs/PHP_UML/{docs,examples}
93 %{php_pear_dir}/.registry/*.reg
94 %{php_pear_dir}/PHP/UML
95 %{php_pear_dir}/PHP/UML.php
96 %{php_pear_dir}/data/PHP_UML
This page took 0.062369 seconds and 4 git commands to generate.