]> git.pld-linux.org Git - packages/php-pear-Net_SmartIRC.git/blob - php-pear-Net_SmartIRC.spec
- fix for variable refs warning; rel 2
[packages/php-pear-Net_SmartIRC.git] / php-pear-Net_SmartIRC.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Net
3 %define         _subclass       SmartIRC
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - IRC client class
8 Summary(pl):    %{_pearname} - klasa klienta IRC
9 Name:           php-pear-%{_pearname}
10 Version:        1.0.0
11 Release:        2
12 License:        LGPL
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  042935bf413e7021aeea2971dd4d3997
16 Patch0:         %{name}-fix_includes.patch
17 Patch1:         %{name}-refs.patch
18 URL:            http://pear.php.net/package/Net_SmartIRC/
19 BuildRequires:  php-pear-PEAR
20 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
21 BuildRequires:  rpmbuild(macros) >= 1.300
22 Requires:       php-pear
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Net_SmartIRC is a PHP class for communication with IRC networks, which
28 conforms to the RFC 2812 (IRC protocol). It's an API that handles all
29 IRC protocol messages. This class is designed for creating IRC bots,
30 chats and show irc related info on webpages.
31
32 Featurelist:
33 - actionhandler for the API
34 - messagehandler for the API
35 - send/receive floodprotection
36 - detects and changes nickname on nickname collisions
37 - time events
38 - full object oriented programmed
39 - autoreconnect
40 - debugging/logging system
41 - supports fsocks and PHP socket extension
42 - supports PHP 4.1.x to 4.3.0
43 - sendbuffer with priority levels
44 - channel synching (tracking of users/modes/topic etc in variables)
45 - IRC functions: op, deop, voice, devoice, ban, unban, join, part,
46   action, message, query, ctcp, mode, topic, nick, invite
47
48 In PEAR status of this package is: %{_status}.
49
50 %description -l pl
51 Net_SmartIRC to klasa PHP do komunikacji z sieciami IRC zgodnymi z RFC
52 2812 (protoko³em IRC). Jest to API obs³uguj±ce wszystkie komunikaty
53 protoko³u IRC. Ta klasa zosta³a zaprojektowana do tworzenia botów
54 ircowych, chatów i pokazywania informacji zwi±zanych z ircem na
55 stronach WWW.
56
57 Lista mo¿liwo¶ci:
58 - obs³uga akcji dla API
59 - obs³uga komunikatów dla API
60 - zabezpieczenie przed zapchaniem przy wysy³aniu/odbieraniu
61 - wykrywanie i zmiana pseudonimów w przypadku kolizji
62 - zdarzenia czasowe
63 - w pe³ni obiektowo zorientowane programowanie
64 - automatyczne wznawianie po³±czeñ
65 - system ¶ledzenia i logowania
66 - obs³uga rozszerzeñ PHP fsocks i socket
67 - zgodno¶æ z PHP od 4.1.x do 4.3.0
68 - sendbuffer z priorytetami
69 - synchronizacja kana³ów (¶ledzienie u¿ytkowników/trybów/motywów w
70   zmiennych)
71 - funkcje IRC: op, deop, voice, devoice, ban, unban, join, part,
72   action, message, query, ctcp, mode, topic, nick, invite.
73
74 Ta klasa ma w PEAR status: %{_status}.
75
76 %prep
77 %pear_package_setup
78 cd ./%{php_pear_dir}/%{_class}
79 %patch0 -p1
80 %patch1 -p1
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{php_pear_dir}
85 %pear_package_install
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc install.log
93 %doc docs/%{_pearname}/docs/*
94 %doc docs/%{_pearname}/{CHANGELOG,CREDITS,FEATURES,README}
95 %dir %{php_pear_dir}/%{_class}/%{_subclass}
96 %{php_pear_dir}/.registry/*.reg
97 %{php_pear_dir}/%{_class}/*.php
98 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.069882 seconds and 4 git commands to generate.