]> git.pld-linux.org Git - packages/php-pear-Net_SmartIRC.git/blob - php-pear-Net_SmartIRC.spec
- massive manual attack: pear packages update
[packages/php-pear-Net_SmartIRC.git] / php-pear-Net_SmartIRC.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Net
3 %define         _subclass       SmartIRC
4 %define         _status         stable
5
6 %define         _pearname       %{_class}_%{_subclass}
7 Summary:        %{_pearname} - IRC Client Class
8 Summary(pl):    %{_pearname} - Klasa klienta IRC
9 Name:           php-pear-%{_pearname}
10 Version:        0.5.1
11 Release:        1
12 License:        LGPL
13 Group:          Development/Languages/PHP
14 # Source0-md5:  971f0345e49f1318d31854ea96be0a17
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 URL:            http://sf.net/projects/phpsmartirc/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Net_SmartIRC is a PHP class for communication with IRC networks, which
24 conforms to the RFC 2812 (IRC protocol). It's an API that handles all
25 IRC protocol messages. This class is designed for creating IRC bots,
26 chats and show irc related info on webpages.
27
28 Featurelist:
29 - actionhandler for the API
30 - messagehandler for the API
31 - send/receive floodprotection
32 - detects and changes nickname on nickname collisions
33 - time events
34 - full object oriented programmed
35 - autoreconnect
36 - debugging/logging system
37 - supports fsocks and PHP socket extension
38 - supports PHP 4.1.x to 4.3.0
39 - sendbuffer with priority levels
40 - channel synching (tracking of users/modes/topic etc in variables)
41 - IRC functions: op, deop, voice, devoice, ban, unban, join, part,
42   action, message, query, ctcp, mode, topic, nick, invite
43
44 This class has in PEAR status: %{_status}.
45
46 %description -l pl
47 Net_SmartIRC to klasa PHP do komunikacji z sieciami IRC zgodnymi z RFC
48 2812 (protoko³em IRC). Jest to API obs³uguj±ce wszystkie komunikaty
49 protoko³u IRC. Ta klasa zosta³a zaprojektowana do tworzenia botów
50 ircowych, chatów i pokazywania informacji zwi±zanych z ircem na
51 stronach WWW.
52
53 Lista mo¿liwo¶ci:
54 - obs³uga akcji dla API
55 - obs³uga komunikatów dla API
56 - zabezpieczenie przed zapchaniem przy wysy³aniu/odbieraniu
57 - wykrywanie i zmiana pseudonimów w przypadku kolizji
58 - zdarzenia czasowe
59 - w pe³ni obiektowo zorientowane programowanie
60 - automatyczne wznawianie po³±czeñ
61 - system ¶ledzenia i logowania
62 - obs³uga rozszerzeñ PHP fsocks i socket
63 - zgodno¶æ z PHP od 4.1.x do 4.3.0
64 - sendbuffer z priorytetami
65 - synchronizacja kana³ów (¶ledzienie u¿ytkowników/trybów/motywów w
66   zmiennych)
67 - funkcje IRC: op, deop, voice, devoice, ban, unban, join, part,
68   action, message, query, ctcp, mode, topic, nick, invite.
69
70 Ta klasa ma w PEAR status: %{_status}.
71
72 %prep
73 %setup -q -c
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
78
79 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
80 install %{_pearname}-%{version}/SmartIRC/{defines,messagehandler}.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc %{_pearname}-%{version}/%{_subclass}/{README,HOWTO,FEATURES,DOCUMENTATION,CHANGELOG,CREDITS,example*.php,docs}
88 %dir %{php_pear_dir}/%{_class}/%{_subclass}
89 %{php_pear_dir}/%{_class}/*.php
90 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.082794 seconds and 4 git commands to generate.