]> git.pld-linux.org Git - packages/php-pear-Net_SmartIRC.git/blob - php-pear-Net_SmartIRC.spec
- s/temat/motyw/g
[packages/php-pear-Net_SmartIRC.git] / php-pear-Net_SmartIRC.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Net
3 %define         _subclass       SmartIRC
4 %define         _status         beta
5
6 %define         _pearname       %{_class}_%{_subclass}
7 Summary:        %{_pearname} - IRC Client Class
8 Summary(pl):    %{_pearname} - Klasa klienta IRC
9 Name:           php-pear-%{_pearname}
10 Version:        0.5.0
11 Release:        0.9
12 License:        LGPL
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 URL:            http://sf.net/projects/phpsmartirc/
16 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
17 Requires:       php-pear
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Net_SmartIRC is a PHP class for communication with IRC networks, which
23 conforms to the RFC 2812 (IRC protocol). It's an API that handles all
24 IRC protocol messages. This class is designed for creating IRC bots,
25 chats and show irc related info on webpages.
26
27 Featurelist:
28 - actionhandler for the API
29 - messagehandler for the API
30 - send/receive floodprotection
31 - detects and changes nickname on nickname collisions
32 - time events
33 - full object oriented programmed
34 - autoreconnect
35 - debugging/logging system
36 - supports fsocks and PHP socket extension
37 - supports PHP 4.1.x to 4.3.0
38 - sendbuffer with priority levels
39 - channel synching (tracking of users/modes/topic etc in variables)
40 - IRC functions: op, deop, voice, devoice, ban, unban, join, part,
41   action, message, query, ctcp, mode, topic, nick, invite
42
43 This class has in PEAR status: %{_status}.
44
45 %description -l pl
46 Net_SmartIRC to klasa PHP do komunikacji z sieciami IRC zgodnymi z RFC
47 2812 (protoko³em IRC). Jest to API obs³uguj±ce wszystkie komunikaty
48 protoko³u IRC. Ta klasa zosta³a zaprojektowana do tworzenia botów
49 ircowych, chatów i pokazywania informacji zwi±zanych z ircem na
50 stronach WWW.
51
52 Lista mo¿liwo¶ci:
53 - obs³uga akcji dla API
54 - obs³uga komunikatów dla API
55 - zabezpieczenie przed zapchaniem przy wysy³aniu/odbieraniu
56 - wykrywanie i zmiana pseudonimów w przypadku kolizji
57 - zdarzenia czasowe
58 - w pe³ni obiektowo zorientowane programowanie
59 - automatyczne wznawianie po³±czeñ
60 - system ¶ledzenia i logowania
61 - obs³uga rozszerzeñ PHP fsocks i socket
62 - zgodno¶æ z PHP od 4.1.x do 4.3.0
63 - sendbuffer z priorytetami
64 - synchronizacja kana³ów (¶ledzienie u¿ytkowników/trybów/motywów w
65   zmiennych)
66 - funkcje IRC: op, deop, voice, devoice, ban, unban, join, part,
67   action, message, query, ctcp, mode, topic, nick, invite.
68
69 Ta klasa ma w PEAR status: %{_status}.
70
71 %prep
72 %setup -q -c
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
77
78 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
79 install %{_pearname}-%{version}/SmartIRC/{defines,messagehandler}.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc %{_pearname}-%{version}/%{_subclass}/{README,HOWTO,FEATURES,DOCUMENTATION,CHANGELOG,CREDITS,example*.php,docs}
87 %dir %{php_pear_dir}/%{_class}/%{_subclass}
88 %{php_pear_dir}/%{_class}/*.php
89 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.066695 seconds and 4 git commands to generate.