]> git.pld-linux.org Git - packages/php-pear-Net_SmartIRC.git/blob - php-pear-Net_SmartIRC.spec
- initial release
[packages/php-pear-Net_SmartIRC.git] / php-pear-Net_SmartIRC.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Net
3 %define         _subclass       SmartIRC
4 %define         _status         beta
5
6 %define         _pearname       %{_class}_%{_subclass}
7 Summary:        %{_pearname} - IRC Client Class
8 Summary(pl):    %{_pearname} - Klasa klienta IRC
9 Name:           php-pear-%{_pearname}
10 Version:        0.5.0
11 Release:        0.9
12 License:        LGPL
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 URL:            http://sf.net/projects/phpsmartirc/
16 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
17 Requires:       php-pear
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Net_SmartIRC is a PHP class for communication with IRC networks,
23 which conforms to the RFC 2812 (IRC protocol).
24 It's an API that handles all IRC protocol messages.
25 This class is designed for creating IRC bots, chats and show irc related info on webpages.
26
27 Featurelist:
28 - actionhandler for the API
29 - messagehandler for the API
30 - send/receive floodprotection
31 - detects and changes nickname on nickname collisions
32 - time events
33 - full object oriented programmed
34 - autoreconnect
35 - debugging/logging system
36 - supports fsocks and PHP socket extension
37 - supports PHP 4.1.x to 4.3.0
38 - sendbuffer with priority levels
39 - channel synching (tracking of users/modes/topic etc in variables)
40 - IRC functions: op, deop, voice, devoice, ban, unban, join, part, action, message, query, ctcp, mode, topic, nick, invite 
41
42 This class has in PEAR status: %{_status}.
43
44 %description -l pl
45
46 Ta klasa ma w PEAR status: %{_status}.
47
48 %prep
49 %setup -q -c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
54
55 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
56 install %{_pearname}-%{version}/SmartIRC/{defines,messagehandler}.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc %{_pearname}-%{version}/%{_subclass}/{README,HOWTO,FEATURES,DOCUMENTATION,CHANGELOG,CREDITS,example*.php,docs}
64 %dir %{php_pear_dir}/%{_class}/%{_subclass}
65 %{php_pear_dir}/%{_class}/*.php
66 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.077588 seconds and 4 git commands to generate.