]> git.pld-linux.org Git - packages/php-pear-Net_SmartIRC.git/blob - php-pear-Net_SmartIRC.spec
- updated to 0.5.5pl1
[packages/php-pear-Net_SmartIRC.git] / php-pear-Net_SmartIRC.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Net
3 %define         _subclass       SmartIRC
4 %define         _status         stable
5
6 %define         _pearname       %{_class}_%{_subclass}
7 Summary:        %{_pearname} - IRC Client Class
8 Summary(pl):    %{_pearname} - Klasa klienta IRC
9 Name:           php-pear-%{_pearname}
10 Version:        0.5.5p1
11 Release:        1
12 License:        LGPL
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  b51a6edd91bcf66c5027939c1bee6325
16 Patch0:         %{name}-fix_includes.patch
17 URL:            http://sf.net/projects/phpsmartirc/
18 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
19 #Provides:      pear(SmartIRC/defines.php) pear(SmartIRC/messagehandler.php)
20 Requires:       php-pear
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Net_SmartIRC is a PHP class for communication with IRC networks, which
26 conforms to the RFC 2812 (IRC protocol). It's an API that handles all
27 IRC protocol messages. This class is designed for creating IRC bots,
28 chats and show irc related info on webpages.
29
30 Featurelist:
31 - actionhandler for the API
32 - messagehandler for the API
33 - send/receive floodprotection
34 - detects and changes nickname on nickname collisions
35 - time events
36 - full object oriented programmed
37 - autoreconnect
38 - debugging/logging system
39 - supports fsocks and PHP socket extension
40 - supports PHP 4.1.x to 4.3.0
41 - sendbuffer with priority levels
42 - channel synching (tracking of users/modes/topic etc in variables)
43 - IRC functions: op, deop, voice, devoice, ban, unban, join, part,
44   action, message, query, ctcp, mode, topic, nick, invite
45
46 This class has in PEAR status: %{_status}.
47
48 %description -l pl
49 Net_SmartIRC to klasa PHP do komunikacji z sieciami IRC zgodnymi z RFC
50 2812 (protoko³em IRC). Jest to API obs³uguj±ce wszystkie komunikaty
51 protoko³u IRC. Ta klasa zosta³a zaprojektowana do tworzenia botów
52 ircowych, chatów i pokazywania informacji zwi±zanych z ircem na
53 stronach WWW.
54
55 Lista mo¿liwo¶ci:
56 - obs³uga akcji dla API
57 - obs³uga komunikatów dla API
58 - zabezpieczenie przed zapchaniem przy wysy³aniu/odbieraniu
59 - wykrywanie i zmiana pseudonimów w przypadku kolizji
60 - zdarzenia czasowe
61 - w pe³ni obiektowo zorientowane programowanie
62 - automatyczne wznawianie po³±czeñ
63 - system ¶ledzenia i logowania
64 - obs³uga rozszerzeñ PHP fsocks i socket
65 - zgodno¶æ z PHP od 4.1.x do 4.3.0
66 - sendbuffer z priorytetami
67 - synchronizacja kana³ów (¶ledzienie u¿ytkowników/trybów/motywów w
68   zmiennych)
69 - funkcje IRC: op, deop, voice, devoice, ban, unban, join, part,
70   action, message, query, ctcp, mode, topic, nick, invite.
71
72 Ta klasa ma w PEAR status: %{_status}.
73
74 %prep
75 %setup -q -c
76 %patch0 -p0
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
81
82 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
83 install %{_pearname}-%{version}/SmartIRC/{defines,messagehandler}.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc %{_pearname}-%{version}/{CHANGELOG,CREDITS,FEATURES,LICENSE,README,docs,examples}
91 %dir %{php_pear_dir}/%{_class}/%{_subclass}
92 %{php_pear_dir}/%{_class}/*.php
93 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.104032 seconds and 4 git commands to generate.