]> git.pld-linux.org Git - packages/php-pear-HTML_Template_IT.git/blob - php-pear-HTML_Template_IT.spec
b2f4c872b47ffc16a14b8607cb985b266b43275b
[packages/php-pear-HTML_Template_IT.git] / php-pear-HTML_Template_IT.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       Template
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}_IT
6 Summary:        %{_pearname} - Integrated Templates
7 Summary(pl):    %{_pearname} - zintegrowane szablony
8 Name:           php-pear-%{_pearname}
9 Version:        1.1.1
10 Release:        1
11 License:        PHP 2.02
12 Group:          Development/Languages/PHP
13 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
14 Patch0:         %{name}-cosmetic.patch
15 URL:            http://pear.php.net/
16 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
17 Requires:       php-pear
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 HTML_Template_IT: Simple template API. The Isotemplate API is somewhat
23 tricky for a beginner although it is the best one you can build.
24 template::parse() [phplib template = Isotemplate] requests you to name
25 a source and a target where the current block gets parsed into. Source
26 and target can be block names or even handler names. This API gives
27 you a maximum of fexibility but you always have to know what you do
28 which is quite unusual for php skripter like me. I noticed that I do
29 not any control on which block gets parsed into which one. If all
30 blocks are within one file, the script knows how they are nested and
31 in which way you have to parse them. IT knows that inner1 is a child
32 of block2, there's no need to tell him about this. Features:
33  - Nested blocks,
34  - Include external file,
35  - Custom tags format (default {mytag}).
36
37 HTML_Template_ITX: With this class you get the full power of the
38 phplib template class. You may have one file with blocks in it but you
39 have as well one main file and multiple files one for each block. This
40 is quite useful when you have user configurable websites. Using
41 blocks not in the main template allows you to modify some parts of
42 your layout easily.
43
44 This class has in PEAR status: %{_status}.
45
46 %description -l pl
47 HTML_Template_IT - proste API do szablonów. API Isotemplate (template
48 z phplib) jest nieco zawi³e dla pocz±tkuj±cych, ale jest najlepszym
49 jakie mo¿na uzyskaæ. template::parse() wymaga nazwania ¼ród³a i celu,
50 do którego przetworzony bêdzie aktualny blok. ¬ród³o i cel mog± byæ
51 nazwami bloków lub nawet nazwami funkcji obs³uguj±cych. To API daje
52 maksymaln± elastyczno¶æ, ale wymaga zawsze wiedzy, co siê robi, co
53 nie jest normalnym stanem dla niektórych autorów skryptów PHP, takich
54 jak autor tego modu³u. Zauwa¿y³ on, ¿e nie potrzebuje ¿adnej kontroli,
55 który blok zostaje przetworzony na który. Je¿eli wszystkie bloki s± w
56 jednym pliku, skrypt wie, jak s± zagnie¿d¿one i w jaki sposób powinny
57 zostaæ przetworzone. IT wie, ¿e inner1 jest potomkiem block2, nie ma
58 potrzeby podawania mu tych informacji. Mo¿liwo¶ci:
59  - zagnie¿d¿one bloki,
60  - do³±czanie zewnêtrznych plików,
61  - w³asny format znaczników (domy¶lnie {mytag}).
62
63 HTML_Template_ITX - ta klasa daje ca³± si³ê klasy szablonów z phplib.
64 Mo¿na mieæ jeden plik z blokami, ale mo¿na tak¿e mieæ jeden g³ówny
65 plik i wiele plików zawieraj±cych po jednym bloku. Jest to przydatne,
66 aby pozwoliæ u¿ytkownikowi na konfigurowalne serwisy. Przez u¿ycie
67 bloków spoza g³ównego szablonu pozwala siê na ³atwe modyfikowanie
68 niektórych czê¶ci wygl±du.
69
70 Ta klasa ma w PEAR status: %{_status}.
71
72 %prep
73 %setup -q -c
74 cd %{_pearname}-%{version}
75 %patch0 -p1
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
80
81 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.025602 seconds and 2 git commands to generate.