]> git.pld-linux.org Git - packages/php-pear-HTML_Template_IT.git/blob - php-pear-HTML_Template_IT.spec
- 1.1.2
[packages/php-pear-HTML_Template_IT.git] / php-pear-HTML_Template_IT.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       Template
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}_IT
6
7 Summary:        %{_pearname} - Integrated Templates
8 Summary(pl):    %{_pearname} - zintegrowane szablony
9 Name:           php-pear-%{_pearname}
10 Version:        1.1.2
11 Release:        1
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  d0beef293b28ff2b92f05457ad884256
16 URL:            http://pear.php.net/package/HTML_Template_IT/
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
18 Requires:       php-pear
19 Requires:       php-pear-PEAR
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # included in tests
24 %define         _noautoreq 'pear(Console_TestListener.php)' 'pear(IT_api_testcase.php)' 'pear(IT_usage_testcase.php)'
25
26 %description
27 HTML_Template_IT: Simple template API. The Isotemplate API is somewhat
28 tricky for a beginner although it is the best one you can build.
29 template::parse() [phplib template = Isotemplate] requests you to name
30 a source and a target where the current block gets parsed into. Source
31 and target can be block names or even handler names. This API gives
32 you a maximum of fexibility but you always have to know what you do
33 which is quite unusual for PHP skripter like me. I noticed that I do
34 not any control on which block gets parsed into which one. If all
35 blocks are within one file, the script knows how they are nested and
36 in which way you have to parse them. IT knows that inner1 is a child
37 of block2, there's no need to tell him about this. Features:
38  - Nested blocks,
39  - Include external file,
40  - Custom tags format (default {mytag}).
41
42 HTML_Template_ITX: With this class you get the full power of the
43 phplib template class. You may have one file with blocks in it but you
44 have as well one main file and multiple files one for each block. This
45 is quite useful when you have user configurable websites. Using blocks
46 not in the main template allows you to modify some parts of your
47 layout easily.
48
49 In PEAR status of this package is: %{_status}.
50
51 %description -l pl
52 HTML_Template_IT - proste API do szablonów. API Isotemplate (template
53 z phplib) jest nieco zawi³e dla pocz±tkuj±cych, ale jest najlepszym
54 jakie mo¿na uzyskaæ. template::parse() wymaga nazwania ¼ród³a i celu,
55 do którego przetworzony bêdzie aktualny blok. ¬ród³o i cel mog± byæ
56 nazwami bloków lub nawet nazwami funkcji obs³uguj±cych. To API daje
57 maksymaln± elastyczno¶æ, ale wymaga zawsze wiedzy, co siê robi, co nie
58 jest normalnym stanem dla niektórych autorów skryptów PHP, takich jak
59 autor tego modu³u. Zauwa¿y³ on, ¿e nie potrzebuje ¿adnej kontroli,
60 który blok zostaje przetworzony na który. Je¿eli wszystkie bloki s± w
61 jednym pliku, skrypt wie, jak s± zagnie¿d¿one i w jaki sposób powinny
62 zostaæ przetworzone. IT wie, ¿e inner1 jest potomkiem block2, nie ma
63 potrzeby podawania mu tych informacji. Mo¿liwo¶ci:
64  - zagnie¿d¿one bloki,
65  - do³±czanie zewnêtrznych plików,
66  - w³asny format znaczników (domy¶lnie {mytag}).
67
68 HTML_Template_ITX - ta klasa daje ca³± si³ê klasy szablonów z phplib.
69 Mo¿na mieæ jeden plik z blokami, ale mo¿na tak¿e mieæ jeden g³ówny
70 plik i wiele plików zawieraj±cych po jednym bloku. Jest to przydatne,
71 aby pozwoliæ u¿ytkownikowi na konfigurowalne serwisy. Przez u¿ycie
72 bloków spoza g³ównego szablonu pozwala siê na ³atwe modyfikowanie
73 niektórych czê¶ci wygl±du.
74
75 Ta klasa ma w PEAR status: %{_status}.
76
77 %package tests
78 Summary:        Tests for PEAR::%{_pearname}
79 Summary(pl):    Testy dla PEAR::%{_pearname}
80 Group:          Development
81 Requires:       %{name} = %{version}-%{release}
82
83 %description tests
84 Tests for PEAR::%{_pearname}.
85
86 %description tests -l pl
87 Testy dla PEAR::%{_pearname}.
88
89 %prep
90 %pear_package_setup
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{php_pear_dir}
95 %pear_package_install
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc install.log
103 %{php_pear_dir}/.registry/*.reg
104 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
105
106 %files tests
107 %defattr(644,root,root,755)
108 %{php_pear_dir}/tests/*
This page took 1.618496 seconds and 3 git commands to generate.