]> git.pld-linux.org Git - packages/php-pear-HTML_Template_IT.git/blob - php-pear-HTML_Template_IT.spec
76e8d28ee031b92850d73ae713d953aa229ccbd8
[packages/php-pear-HTML_Template_IT.git] / php-pear-HTML_Template_IT.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       Template
4 %define         _pearname       %{_class}_%{_subclass}_IT
5 Summary:        %{_pearname} - Integrated Templates
6 Summary(pl):    %{_pearname} - zintegrowane szablony
7 Name:           php-pear-%{_pearname}
8 Version:        1.0.0
9 Release:        2
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
13 URL:            http://pear.php.net/
14 BuildRequires:  rpm-php-pearprov
15 Requires:       php-pear
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 HTML_Template_IT: Simple template API. The Isotemplate API is somewhat
21 tricky for a beginner although it is the best one you can build.
22 template::parse() [phplib template = Isotemplate] requests you to name
23 a source and a target where the current block gets parsed into. Source
24 and target can be block names or even handler names. This API gives
25 you a maximum of fexibility but you always have to know what you do
26 which is quite unusual for php skripter like me. I noticed that I do
27 not any control on which block gets parsed into which one. If all
28 blocks are within one file, the script knows how they are nested and
29 in which way you have to parse them. IT knows that inner1 is a child
30 of block2, there's no need to tell him about this. Features:
31  - Nested blocks,
32  - Include external file,
33  - Custom tags format (default {mytag}).
34
35 HTML_Template_ITX: With this class you get the full power of the
36 phplib template class. You may have one file with blocks in it but you
37 have as well one main file and multiple files one for each block. This
38 is quite useful when you have user configurable websites. Using
39 blocks not in the main template allows you to modify some parts of
40 your layout easily.
41
42 %description -l pl
43 HTML_Template_IT - proste API do szablonów. API Isotemplate (template
44 z phplib) jest nieco zawi³e dla pocz±tkuj±cych, ale jest najlepszym
45 jakie mo¿na uzyskaæ. template::parse() wymaga nazwania ¼ród³a i celu,
46 do którego przetworzony bêdzie aktualny blok. ¬ród³o i cel mog± byæ
47 nazwami bloków lub nawet nazwami funkcji obs³uguj±cych. To API daje
48 maksymaln± elastyczno¶æ, ale wymaga zawsze wiedzy, co siê robi, co
49 nie jest normalnym stanem dla niektórych autorów skryptów PHP, takich
50 jak autor tego modu³u. Zauwa¿y³ on, ¿e nie potrzebuje ¿adnej kontroli,
51 który blok zostaje przetworzony na który. Je¿eli wszystkie bloki s± w
52 jednym pliku, skrypt wie, jak s± zagnie¿d¿one i w jaki sposób powinny
53 zostaæ przetworzone. IT wie, ¿e inner1 jest potomkiem block2, nie ma
54 potrzeby podawania mu tych informacji. Mo¿liwo¶ci:
55  - zagnie¿d¿one bloki,
56  - do³±czanie zewnêtrznych plików,
57  - w³asny format znaczników (domy¶lnie {mytag}).
58
59 HTML_Template_ITX - ta klasa daje ca³± si³ê klasy szablonów z phplib.
60 Mo¿na mieæ jeden plik z blokami, ale mo¿na tak¿e mieæ jeden g³ówny
61 plik i wiele plików zawieraj±cych po jednym bloku. Jest to przydatne,
62 aby pozwoliæ u¿ytkownikowi na konfigurowalne serwisy. Przez u¿ycie
63 bloków spoza g³ównego szablonu pozwala siê na ³atwe modyfikowanie
64 niektórych czê¶ci wygl±du.
65
66 %prep
67 %setup -q -c
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
72
73 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.040498 seconds and 2 git commands to generate.