]> git.pld-linux.org Git - packages/php-pear-Games_Chess.git/blob - php-pear-Games_Chess.spec
451b02c63c62b81955504bcaf04da4febf015552
[packages/php-pear-Games_Chess.git] / php-pear-Games_Chess.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Games
3 %define         _subclass       Chess
4 %define         _status         alpha
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - Construct and validate a logical chess game, does not display
8 Summary(pl):    %{_pearname} - Konstruowanie i sprawdzanie poprawno¶ci logicznej gry w szachy
9 Name:           php-pear-%{_pearname}
10 Version:        0.5
11 Release:        0.alpha
12 License:        PHP 3.0
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}alpha.tgz
15 # Source0-md5:  a07dd1348d143267be75effa6818a655
16 URL:            http://pear.php.net/package/Games_Chess/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The logic of handling a chessboard and parsing standard FEN
24 (Farnsworth-Edwards Notation) for describing a position as well as SAN
25 (Standard Algebraic Notation) for describing individual moves is
26 handled. This class can be used as a backend driver for playing chess,
27 or for validating and/or creating PGN files using the File_ChessPGN
28 package.
29
30 Although this package is alpha, it is fully unit-tested. The code
31 works, but the API is fluid, and may change dramatically as it is put
32 into use and better ways are found to use it. When the API stabilizes,
33 the stability will increase.
34
35 This class has in PEAR status: %{_status}.
36
37 %description -l pl
38 Ten modu³ obs³uguje logikê obs³ugi szachownicy i analizy standardu
39 notacji FEN (Farnsworth-Edwards Notation) do opisu pozycji, a tak¿e
40 notacji SAN (Standard Algebraic Notation) do opisu poszczególnych
41 ruchów. Klasa mo¿e byæ u¿ywana jako backend do gry w szachy lub do
42 sprawdzania poprawno¶ci albo tworzenia plików PGN przy u¿yciu pakietu
43 File_ChessPGN.
44
45 Mimo ¿e ten pakiet jest w stanie alpha, jest w pe³ni przetestowany.
46 Kod dzia³a, ale API jest nie ustabilizowane i mo¿e siê zmieniæ
47 drastycznie, je¶li znajd± siê ku temu powody. Kiedy API siê
48 ustabilizuje, zwiêkszy siê stabilno¶æ ca³ej klasy.
49
50 Ta klasa ma w PEAR status: %{_status}.
51
52 %prep
53 %setup -q -c
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
58
59 install %{_pearname}-%{version}alpha/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
60 install %{_pearname}-%{version}alpha/%{_subclass}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc %{_pearname}-%{version}alpha/{tests,examples}
68 %dir %{php_pear_dir}/%{_class}
69 %dir %{php_pear_dir}/%{_class}/%{_subclass}
70 %{php_pear_dir}/%{_class}/*.php
71 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.051228 seconds and 2 git commands to generate.