]> git.pld-linux.org Git - packages/php-pear-DB_NestedSet.git/blob - php-pear-DB_NestedSet.spec
- rel 4 (rebuild with less deps)
[packages/php-pear-DB_NestedSet.git] / php-pear-DB_NestedSet.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          DB
3 %define         _subclass       NestedSet
4 %define         _status         beta
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - API to build and query nested sets
8 Summary(pl):    %{_pearname} - API to tworzenia i wykonywania zagnie¿d¿onych zapytañ
9 Name:           php-pear-%{_pearname}
10 Version:        1.3.6
11 Release:        4
12 Epoch:          0
13 License:        PHP 2.02
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 # Source0-md5:  556e7afbf740c0f18b35bfd820fd75b9
17 URL:            http://pear.php.net/package/DB_NestedSet/
18 BuildRequires:  php-pear-PEAR
19 BuildRequires:  rpm-php-pearprov >= 4.4.2-12
20 Requires:       php-pear
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # included in tests
25 %define         _noautoreq 'pear(TestBase.php)' 'pear(UnitTest.php)'
26
27 %description
28 DB_NestedSet lets you create trees with infinite depth inside a
29 relational database. The package provides a way to:
30 - create/update/delete nodes
31 - query nodes, trees and subtrees
32 - copy (clone) nodes, trees and subtrees
33 - move nodes, trees and subtrees
34 - call event handlers on specific events like on node deletion
35 - output the tree with
36   - PEAR::HTML_TreeMenu
37   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
38 - It also features caching of SQL queries using PEAR::Cache.
39
40 In PEAR status of this package is: %{_status}.
41
42 %description -l pl
43 DB_NestedSet pozwala na tworzenie drzew nieskoñczonej d³ugo¶ci
44 wewn±trz relacyjnych baz danych. Pakiet umo¿liwia:
45 - tworzenie/modyfikowanie/usuwanie wêz³ów
46 - odpytywanie wêz³ów, drzew i poddrzew
47 - kopiowanie (klonowanie) wêz³ów, drzew i poddrzew
48 - przenoszenie wêz³ów, drzew i poddrzew
49 - wywo³ywanie procedur obs³ugi dla okre¶lonych zdarzeñ typu usuwanie
50   wêz³a
51 - pokazanie drzewa przy u¿yciu:
52   - PEAR::HTML_TreeMenu
53   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
54 - mo¿e tak¿e buforowaæ zapytania SQL przy u¿yciu PEAR::Cache.
55
56 Ta klasa ma w PEAR status: %{_status}.
57
58 %package tests
59 Summary:        Tests for PEAR::%{_pearname}
60 Summary(pl):    Testy dla PEAR::%{_pearname}
61 Group:          Development/Languages/PHP
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63 AutoReq:        no
64
65 %description tests
66 Tests for PEAR::%{_pearname}.
67
68 %description tests -l pl
69 Testy dla PEAR::%{_pearname}.
70
71 %prep
72 %pear_package_setup
73
74 # fix tests
75 cd ./%{php_pear_dir}/tests/%{_pearname}/tests
76 # mac line endings!
77 sed -i -e 's,\r,\n,g' index.php
78
79 # make it suitable after install
80 sed -i -e 's,NestedSet.php,DB/NestedSet.php,' *.php
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{php_pear_dir}
85 %pear_package_install
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc install.log
93 %doc docs/%{_pearname}/docs/*
94 %{php_pear_dir}/.registry/*.reg
95 %dir %{php_pear_dir}/%{_class}/%{_subclass}
96 %{php_pear_dir}/%{_class}/*.php
97 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
98
99 %files tests
100 %defattr(644,root,root,755)
101 %{php_pear_dir}/tests/*
This page took 0.062623 seconds and 4 git commands to generate.