]> git.pld-linux.org Git - packages/php-pear-DB_NestedSet.git/blob - php-pear-DB_NestedSet.spec
- group Development/Languages/PHP for -tests
[packages/php-pear-DB_NestedSet.git] / php-pear-DB_NestedSet.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          DB
3 %define         _subclass       NestedSet
4 %define         _status         beta
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - API to build and query nested sets
8 Summary(pl):    %{_pearname} - API to tworzenia i wykonywania zagnie¿d¿onych zapytañ
9 Name:           php-pear-%{_pearname}
10 Version:        1.3.6
11 Release:        3
12 Epoch:          0
13 License:        PHP 2.02
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 # Source0-md5:  556e7afbf740c0f18b35bfd820fd75b9
17 URL:            http://pear.php.net/package/DB_NestedSet/
18 BuildRequires:  rpm-php-pearprov >= 4.4.2-12
19 Requires:       php-pear
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # included in tests
24 %define         _noautoreq 'pear(TestBase.php)' 'pear(UnitTest.php)'
25
26 %description
27 DB_NestedSet lets you create trees with infinite depth inside a
28 relational database. The package provides a way to:
29 - create/update/delete nodes
30 - query nodes, trees and subtrees
31 - copy (clone) nodes, trees and subtrees
32 - move nodes, trees and subtrees
33 - call event handlers on specific events like on node deletion
34 - output the tree with
35   - PEAR::HTML_TreeMenu
36   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
37 - It also features caching of SQL queries using PEAR::Cache.
38
39 In PEAR status of this package is: %{_status}.
40
41 %description -l pl
42 DB_NestedSet pozwala na tworzenie drzew nieskoñczonej d³ugo¶ci
43 wewn±trz relacyjnych baz danych. Pakiet umo¿liwia:
44 - tworzenie/modyfikowanie/usuwanie wêz³ów
45 - odpytywanie wêz³ów, drzew i poddrzew
46 - kopiowanie (klonowanie) wêz³ów, drzew i poddrzew
47 - przenoszenie wêz³ów, drzew i poddrzew
48 - wywo³ywanie procedur obs³ugi dla okre¶lonych zdarzeñ typu usuwanie
49   wêz³a
50 - pokazanie drzewa przy u¿yciu:
51   - PEAR::HTML_TreeMenu
52   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
53 - mo¿e tak¿e buforowaæ zapytania SQL przy u¿yciu PEAR::Cache.
54
55 Ta klasa ma w PEAR status: %{_status}.
56
57 %package tests
58 Summary:        Tests for PEAR::%{_pearname}
59 Summary(pl):    Testy dla PEAR::%{_pearname}
60 Group:          Development/Languages/PHP
61 Requires:       %{name} = %{epoch}:%{version}-%{release}
62 AutoReq:        no
63
64 %description tests
65 Tests for PEAR::%{_pearname}.
66
67 %description tests -l pl
68 Testy dla PEAR::%{_pearname}.
69
70 %prep
71 %pear_package_setup
72
73 # fix tests
74 cd ./%{php_pear_dir}/tests/%{_pearname}/tests
75 # mac line endings!
76 sed -i -e 's,\r,\n,g' index.php
77
78 # make it suitable after install
79 sed -i -e 's,NestedSet.php,DB/NestedSet.php,' *.php
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{php_pear_dir}
84 %pear_package_install
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc install.log
92 %doc docs/%{_pearname}/docs/*
93 %{php_pear_dir}/.registry/*.reg
94 %dir %{php_pear_dir}/%{_class}/%{_subclass}
95 %{php_pear_dir}/%{_class}/*.php
96 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
97
98 %files tests
99 %defattr(644,root,root,755)
100 %{php_pear_dir}/tests/*
This page took 0.035976 seconds and 3 git commands to generate.