]> git.pld-linux.org Git - packages/php-pear-DB_NestedSet.git/blob - php-pear-DB_NestedSet.spec
- bug url
[packages/php-pear-DB_NestedSet.git] / php-pear-DB_NestedSet.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          DB
3 %define         _subclass       NestedSet
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6 Summary:        %{_pearname} - API to build and query nested sets
7 Summary(pl.UTF-8):      %{_pearname} - API to tworzenia i wykonywania zagnieżdżonych zapytań
8 Name:           php-pear-%{_pearname}
9 Version:        1.4.1
10 Release:        2
11 License:        PHP 2.02
12 Group:          Development/Languages/PHP
13 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
14 # Source0-md5:  b906275511a6f4d1e9b1ed95ac6d7546
15 Patch0:         includepath.patch
16 URL:            http://pear.php.net/package/DB_NestedSet/
17 BuildRequires:  php-pear-PEAR
18 BuildRequires:  rpm-php-pearprov >= 4.4.2-12
19 BuildRequires:  rpmbuild(macros) >= 1.300
20 Requires:       php-pear
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # included in tests
25 %define         _noautoreq 'pear(TestBase.php)' 'pear(UnitTest.php)'
26
27 %description
28 DB_NestedSet lets you create trees with infinite depth inside a
29 relational database. The package provides a way to:
30 - create/update/delete nodes
31 - query nodes, trees and subtrees
32 - copy (clone) nodes, trees and subtrees
33 - move nodes, trees and subtrees
34 - call event handlers on specific events like on node deletion
35 - output the tree with
36   - PEAR::HTML_TreeMenu
37   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
38 - It also features caching of SQL queries using PEAR::Cache.
39
40 In PEAR status of this package is: %{_status}.
41
42 %description -l pl.UTF-8
43 DB_NestedSet pozwala na tworzenie drzew nieskończonej długości
44 wewnątrz relacyjnych baz danych. Pakiet umożliwia:
45 - tworzenie/modyfikowanie/usuwanie węzłów
46 - odpytywanie węzłów, drzew i poddrzew
47 - kopiowanie (klonowanie) węzłów, drzew i poddrzew
48 - przenoszenie węzłów, drzew i poddrzew
49 - wywoływanie procedur obsługi dla określonych zdarzeń typu usuwanie
50   węzła
51 - pokazanie drzewa przy użyciu:
52   - PEAR::HTML_TreeMenu
53   - TigraMenu (http://www.softcomplex.com/products/tigra_menu/)
54 - może także buforować zapytania SQL przy użyciu PEAR::Cache.
55
56 Ta klasa ma w PEAR status: %{_status}.
57
58 %package tests
59 Summary:        Tests for PEAR::%{_pearname}
60 Summary(pl.UTF-8):      Testy dla PEAR::%{_pearname}
61 Group:          Development/Languages/PHP
62 Requires:       %{name} = %{version}-%{release}
63 AutoProv:       no
64 AutoReq:        no
65
66 %description tests
67 Tests for PEAR::%{_pearname}.
68
69 %description tests -l pl.UTF-8
70 Testy dla PEAR::%{_pearname}.
71
72 %prep
73 %pear_package_setup
74 %patch0 -p1
75
76 install -d examples
77 mv docs/%{_pearname}/docs/*example.php examples
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{php_pear_dir}
82 %pear_package_install
83
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc install.log
93 %doc docs/%{_pearname}/docs/*
94 %{php_pear_dir}/.registry/*.reg
95 %dir %{php_pear_dir}/%{_class}/%{_subclass}
96 %{php_pear_dir}/%{_class}/*.php
97 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
98
99 %{_examplesdir}/%{name}-%{version}
100
101 %files tests
102 %defattr(644,root,root,755)
103 %{php_pear_dir}/tests/*
This page took 0.039346 seconds and 3 git commands to generate.