]> git.pld-linux.org Git - packages/php-pear-Crypt_Blowfish.git/blob - php-pear-Crypt_Blowfish.spec
- use new pear build system
[packages/php-pear-Crypt_Blowfish.git] / php-pear-Crypt_Blowfish.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Crypt
3 %define         _subclass       Blowfish
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - quick two-way blowfish encryption
8 Summary(pl):    %{_pearname} - szybkie dwustronne szyfrowanie algorytmem blowfish
9 Name:           php-pear-%{_pearname}
10 Version:        1.0.0
11 Release:        1.1
12 License:        PHP
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  02858a3c46db133f95a9b18c36f52688
16 URL:            http://pear.php.net/package/Crypt_Blowfish/
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-10.2
18 BuildRequires:  sed >= 4.0
19 Requires:       php-pear
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package allows you to preform two-way blowfish on the fly using
25 only PHP. This package does not require the Mcrypt PHP extension to
26 work.
27
28 In PEAR status of this package is: %{_status}.
29
30 %description -l pl
31 Ta klasa pozwala na dwustronne szyfrowanie w locie z u¿yciem algorytmu
32 blowfish. Klasa ta nie wymaga rozszerzenia Mcrypt.
33
34 Ta klasa ma w PEAR status: %{_status}.
35
36 %prep
37 %pear_package_setup
38
39 # bad pear package
40 sed -i -e 's,Blowfish/DefaultKey.php,Crypt/Blowfish/DefaultKey.php,' ./%{php_pear_dir}/%{_class}/%{_subclass}.php
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{php_pear_dir}
45 %pear_package_install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc install.log
53 %{php_pear_dir}/.registry/*.reg
54 %{php_pear_dir}/%{_class}/*.php
55 %{php_pear_dir}/%{_class}/%{_subclass}
This page took 0.05102 seconds and 4 git commands to generate.