]> git.pld-linux.org Git - packages/php-pear-Config.git/blob - php-pear-Config.spec
- BR php-pear-PEAR
[packages/php-pear-Config.git] / php-pear-Config.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Config
3 %define         _pearname       %{_class}
4 %define         _status         stable
5
6 Summary:        %{_pearname} - class for reading and writing Config-"files"
7 Summary(pl):    %{_pearname} - klasa do odczytu i zapisu plików konfiguracyjnych
8 Name:           php-pear-%{_pearname}
9 Version:        1.10.6
10 Release:        1
11 License:        PHP 2.02
12 Group:          Development/Languages/PHP
13 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
14 # Source0-md5:  7b7f88c6dc1271e43ebfee7d0b5dc127
15 URL:            http://pear.php.net/package/Config/
16 BuildRequires:  php-pear-PEAR
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _noautoreq      'pear(XML/Parser.*)' 'pear(XML/Util.*)'
23
24 %description
25 The Config package provides methods for editing configuration
26 datasources. It does so in an object oriented manner, defining each
27 and every items found in the config datasource as a Config_Container
28 of various types (comments, sections, directives, blanks, ...). Items
29 can then be edited, added, removed, inserted. This package is not
30 intended for reading configuration data only, but for editing them. If
31 you only want to read your configuration data, use functions like
32 parse_ini_file() and the like instead, they are much faster.
33
34 In PEAR status of this package is: %{_status}.
35
36 %description -l pl
37 Pakiet Config udostêpnia metody do edycji zasobów konfiguracyjnych.
38 Robi to w sposób zorientowany obiektowo, definiuj±c ka¿dy element
39 znaleziony w zasobie konfiguracyjnym jako Config_Container ró¿nych
40 typów (komentarz, sekcja, dyrektywa, odstêp...). Elementy mog± byæ
41 modyfikowane, dodawane, usuwane, wstawiane. Ten pakiet nie ma s³u¿yæ
42 tylko do czytania danych konfiguracyjnych, ale tak¿e do edycji ich.
43 Tylko do czytania danych lepiej u¿ywaæ funkcji typu parse_ini_file(),
44 które s± du¿o szybsze.
45
46 Ta klasa ma w PEAR status: %{_status}.
47
48 %package tests
49 Summary:        Tests for PEAR::%{_pearname}
50 Summary(pl):    Testy dla PEAR::%{_pearname}
51 Group:          Development/Languages/PHP
52 Requires:       %{name} = %{version}-%{release}
53 AutoReq:        no
54
55 %description tests
56 Tests for PEAR::%{_pearname}.
57
58 %description tests -l pl
59 Testy dla PEAR::%{_pearname}.
60
61 %prep
62 %pear_package_setup
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{php_pear_dir}
67 %pear_package_install
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 if [ -f %{_docdir}/%{name}-%{version}/optional-packages.txt ]; then
74         cat %{_docdir}/%{name}-%{version}/optional-packages.txt
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %doc install.log optional-packages.txt
80 %doc docs/%{_pearname}/docs/*
81 %{php_pear_dir}/.registry/*.reg
82 %{php_pear_dir}/*.php
83 %{php_pear_dir}/%{_class}
84
85 %files tests
86 %defattr(644,root,root,755)
87 %{php_pear_dir}/tests/*
This page took 0.06072 seconds and 3 git commands to generate.