]> git.pld-linux.org Git - packages/php-gtk2.git/blob - php-gtk2.spec
- release 2
[packages/php-gtk2.git] / php-gtk2.spec
1 Summary:        PHP language bindings for GTK+ toolkit
2 Summary(pl):    Modu³ PHP z wi±zaniami do GTK+
3 Name:           php-gtk
4 Version:        0.5.0
5 Release:        2
6 License:        GPL
7 Group:          Libraries
8 Source0:        %{name}-%{version}.tar.gz
9 #Source0:       http://gtk.php.net/do_download.php?download_file=%{name}-%{version}
10 URL:            http://gtk.php.net/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  php-cgi
14 BuildRequires:  php-devel
15 BuildRequires:  php-pcre
16 BuildRequires:  libglade-devel
17 BuildRequires:  gtk+-devel
18 Requires:       php-cgi
19 Provides:       pear(gdk)
20 Provides:       pear(GtkWindow)
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     /etc/php
24
25 %description
26 PHP-GTK is a PHP extension that enables you to write client-side
27 cross-platform GUI applications. This is the first such extension of
28 this kind and one of the goals behind it was to prove that PHP is a
29 capable general-purpose scripting language that is suited for more
30 than just Web applications.
31
32 This extension will _not_ allow you to display GTK+ programs in a Web
33 browser, and cannot be used in the Web environment. It is intended for
34 creating standalone GUI applications.
35
36 %description -l pl
37 PHP-GTK jest rozszerzeniem PHP które pozwala pisaæ klienckie przeno¶ne
38 aplikacje typu GUI. To jest pierwsze roszerzenie tego typu i jednym z
39 celów które przy¶wieca³y jego autorom by³o pokazanie ¿e PHP jest
40 jêzykiem skryptowym ogólnego zastosowania, który pasuje do czego¶
41 wiêcej ni¿ tylko aplikacje webowe.
42
43 To roszerzenie _nie_pozwoli_ Ci u¿ywaæ programów korzystaj±cych GTK+
44 przez przegl±darkê i nie mo¿e byæ u¿ywane w ¶rodowisku webowym. Jest
45 przeznaczone do tworzenia samodzielnych aplikacji GUI.
46
47 %prep
48 %setup -q
49
50 %build
51 phpize
52 aclocal
53 %configure
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{_libdir}/php
60
61 install modules/php_gtk.so $RPM_BUILD_ROOT%{_libdir}/php/gtk.so
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %{_sbindir}/php-module-install install gtk %{_sysconfdir}/php.ini
68
69 %preun
70 if [ "$1" = "0" ]; then
71         %{_sbindir}/php-module-install remove gtk %{_sysconfdir}/php.ini
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc ChangeLog AUTHORS TODO NEWS
77 %attr(755,root,root) %{_libdir}/php/*.so
This page took 0.061075 seconds and 4 git commands to generate.