]> git.pld-linux.org Git - packages/photoqt.git/blob - photoqt.spec
update BR
[packages/photoqt.git] / photoqt.spec
1 # TODO
2 # - with GM?
3 # - optional (runtime) deps:
4 #  - XCFtools - https://github.com/j-jorge/xcftools
5 #  - libqpsd - https://github.com/Code-ReaQtor/libqpsd
6 %bcond_with     gm      # build with GraphicsMagic
7
8 %define qtver   5.1
9 Summary:        Simple but powerful Qt-based image viewer
10 Name:           photoqt
11 Version:        1.2
12 Release:        1
13 License:        GPL v2
14 Group:          Applications
15 Source0:        http://photoqt.org/pkgs/%{name}-%{version}.tar.gz
16 # Source0-md5:  bc0233279c86db39dc2482583697c9b3
17 URL:            http://photoqt.org/
18 %{?with_gm:BuildRequires:       GraphicsMagick-devel}
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Gui-devel >= %{qtver}
21 BuildRequires:  Qt5Multimedia-devel >= %{qtver}
22 BuildRequires:  Qt5Sql-devel >= %{qtver}
23 BuildRequires:  Qt5Svg-devel >= %{qtver}
24 BuildRequires:  Qt5Widgets-devel >= %{qtver}
25 BuildRequires:  cmake
26 BuildRequires:  exiv2-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  qt5-linguist >= %{qtver}
30 BuildRequires:  qt5-qmake >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.596
32 Requires:       desktop-file-utils
33 Requires:       gtk-update-icon-cache
34 Requires:       hicolor-icon-theme
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Simple but powerful Qt-based image viewer.
39
40 %prep
41 %setup -q
42
43 %build
44 install -d build
45 cd build
46 %cmake \
47         -DGM=NO \
48         -DEXIV2=YES \
49         ..
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} -C build install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %update_desktop_database
62 %update_icon_cache hicolor
63
64 %postun
65 %update_desktop_database
66 %update_icon_cache hicolor
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README CHANGELOG
71 %attr(755,root,root) %{_bindir}/photoqt
72 %{_desktopdir}/photoqt.desktop
73 %{_iconsdir}/hicolor/*/apps/photoqt.png
This page took 0.468778 seconds and 4 git commands to generate.