]> git.pld-linux.org Git - packages/phonon.git/blob - phonon.spec
- rel 2; build with libqzeitgeist
[packages/phonon.git] / phonon.spec
1 %define         qtver           4.7.2
2
3 Summary:        Multimedia API for Qt4/KDE4
4 Summary(pl.UTF-8):      Biblioteka Phonon
5 Name:           phonon
6 Version:        4.5.0
7 Release:        2
8 License:        LGPL v2.1
9 Group:          X11/Libraries
10 Source0:        ftp://ftp.kde.org/pub/kde/stable/phonon/%{version}/src/%{name}-%{version}.tar.bz2
11 # Source0-md5:  32f8d388c18fde2e23dea7bb103f9713
12 Patch0:         %{name}-pkg.patch
13 URL:            http://phonon.kde.org/
14 BuildRequires:  QtCore-devel >= %{qtver}
15 BuildRequires:  QtDBus-devel >= %{qtver}
16 BuildRequires:  QtNetwork-devel >= %{qtver}
17 BuildRequires:  QtOpenGL-devel >= %{qtver}
18 BuildRequires:  QtSql-devel >= %{qtver}
19 BuildRequires:  QtTest-devel >= %{qtver}
20 BuildRequires:  automoc4 >= 0.9.86
21 BuildRequires:  cmake >= 2.8.0
22 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.0
23 BuildRequires:  libqzeitgeist-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  pulseaudio-devel >= 0.9.21
26 BuildRequires:  qt4-build >= %{qtver}
27 BuildRequires:  qt4-qmake >= %{qtver}
28 BuildRequires:  rpmbuild(macros) >= 1.293
29 BuildRequires:  xine-lib-devel >= 2:1.1.15-4
30 Requires:       kde-common-dirs >= 0.5
31 Suggests:       qt4-phonon-backend
32 Provides:       qt4-phonon
33 Obsoletes:      qt4-phonon
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Phonon is the multimedia API for Qt4/KDE4.
38
39 Phonon was originally created to allow KDE 4 to be independent of any
40 single multimedia framework such as GStreamer or Xine and to provide a
41 stable API for KDE4's lifetime. It was done to fix problems of
42 frameworks becoming unmaintained, API instability, and to create a
43 simple multimedia API.
44
45 %description -l pl.UTF-8
46 Biblioteka phonon.
47
48 %package devel
49 Summary:        Header files for Phonon library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Phonon
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       QtCore-devel >= %{qtver}
54 Requires:       QtDBus-devel >= %{qtver}
55 Requires:       QtGui-devel >= %{qtver}
56 Provides:       qt4-phonon-devel
57 Obsoletes:      qt4-phonon-devel
58
59 %description devel
60 Header files for Phonon library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki Phonon.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 %build
70 install -d build
71 cd build
72 %cmake \
73         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
74         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
75 %if "%{_lib}" == "lib64"
76         -DLIB_SUFFIX=64 \
77 %endif
78         ..
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85
86 %{__make} -C build install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 install -d $RPM_BUILD_ROOT%{_includedir}/qt4
90 install -d $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend
91 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends
92 ln -s ../phonon $RPM_BUILD_ROOT%{_includedir}/qt4/phonon
93 ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libphonon.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libphonon.so.4
105 %attr(755,root,root) %{_libdir}/libphononexperimental.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libphononexperimental.so.4
107 %{_datadir}/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
108 %dir %{_libdir}/kde4/plugins/phonon_backend
109 %dir %{_datadir}/kde4/services/phononbackends
110
111 %files devel
112 %defattr(644,root,root,755)
113 %{_libdir}/libphonon.so
114 %{_libdir}/libphononexperimental.so
115 %{_includedir}/phonon
116 %dir %{_includedir}/KDE
117 %{_includedir}/KDE/Phonon
118 %{_includedir}/qt4/phonon
119 %{_pkgconfigdir}/phonon.pc
120 %{_datadir}/phonon-buildsystem
121 %{_datadir}/qt4/mkspecs/modules/qt_phonon.pri
This page took 0.040076 seconds and 4 git commands to generate.