]> git.pld-linux.org Git - packages/phonon.git/blob - phonon.spec
- up to 4.5.0
[packages/phonon.git] / phonon.spec
1 %define         qtver           4.7.2
2
3 Summary:        Multimedia API for Qt4/KDE4
4 Summary(pl.UTF-8):      Biblioteka Phonon
5 Name:           phonon
6 Version:        4.5.0
7 Release:        1
8 License:        LGPL v2.1
9 Group:          X11/Libraries
10 Source0:        ftp://ftp.kde.org/pub/kde/stable/phonon/%{version}/src/%{name}-%{version}.tar.bz2
11 # Source0-md5:  32f8d388c18fde2e23dea7bb103f9713
12 Patch0:         %{name}-pkg.patch
13 URL:            http://phonon.kde.org/
14 BuildRequires:  QtCore-devel >= %{qtver}
15 BuildRequires:  QtDBus-devel >= %{qtver}
16 BuildRequires:  QtNetwork-devel >= %{qtver}
17 BuildRequires:  QtOpenGL-devel >= %{qtver}
18 BuildRequires:  QtSql-devel >= %{qtver}
19 BuildRequires:  QtTest-devel >= %{qtver}
20 BuildRequires:  automoc4 >= 0.9.86
21 BuildRequires:  cmake >= 2.8.0
22 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  pulseaudio-devel >= 0.9.21
25 BuildRequires:  qt4-build >= %{qtver}
26 BuildRequires:  qt4-qmake >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.293
28 BuildRequires:  xine-lib-devel >= 2:1.1.15-4
29 Requires:       kde-common-dirs >= 0.5
30 Suggests:       qt4-phonon-backend
31 Provides:       qt4-phonon
32 Obsoletes:      qt4-phonon
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Phonon is the multimedia API for Qt4/KDE4.
37
38 Phonon was originally created to allow KDE 4 to be independent of any
39 single multimedia framework such as GStreamer or Xine and to provide a
40 stable API for KDE4's lifetime. It was done to fix problems of
41 frameworks becoming unmaintained, API instability, and to create a
42 simple multimedia API.
43
44 %description -l pl.UTF-8
45 Biblioteka phonon.
46
47 %package devel
48 Summary:        Header files for Phonon library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Phonon
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       QtCore-devel >= %{qtver}
53 Requires:       QtDBus-devel >= %{qtver}
54 Requires:       QtGui-devel >= %{qtver}
55 Provides:       qt4-phonon-devel
56 Obsoletes:      qt4-phonon-devel
57
58 %description devel
59 Header files for Phonon library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki Phonon.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 install -d build
70 cd build
71 %cmake \
72         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
73         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
74 %if "%{_lib}" == "lib64"
75         -DLIB_SUFFIX=64 \
76 %endif
77         ..
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84
85 %{__make} -C build install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 install -d $RPM_BUILD_ROOT%{_includedir}/qt4
89 install -d $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend
90 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends
91 ln -s ../phonon $RPM_BUILD_ROOT%{_includedir}/qt4/phonon
92 ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libphonon.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libphonon.so.4
104 %attr(755,root,root) %{_libdir}/libphononexperimental.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libphononexperimental.so.4
106 %{_datadir}/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
107 %dir %{_libdir}/kde4/plugins/phonon_backend
108 %dir %{_datadir}/kde4/services/phononbackends
109
110 %files devel
111 %defattr(644,root,root,755)
112 %{_libdir}/libphonon.so
113 %{_libdir}/libphononexperimental.so
114 %{_includedir}/phonon
115 %dir %{_includedir}/KDE
116 %{_includedir}/KDE/Phonon
117 %{_includedir}/qt4/phonon
118 %{_pkgconfigdir}/phonon.pc
119 %{_datadir}/phonon-buildsystem
120 %{_datadir}/qt4/mkspecs/modules/qt_phonon.pri
This page took 0.030757 seconds and 4 git commands to generate.