]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
- added epoch to perl-devel BR
[projects/template-specs.git] / perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    -
7 %define pnam    -
8 Summary:        -
9 Summary(de):    -
10 Summary(es):    -
11 Summary(fr):    -
12 Summary(pl):    -
13 Summary(ru):    -
14 Name:           perl-
15 Version:        -
16 Release:        -
17 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
18 Group:          Development/Languages/Perl
19 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
20 Patch0:         %{name}
21 URL:            -
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  -
25 Requires:       -
26 Provides:       -
27 Obsoletes:      -
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautoreq      'perl(anything_fake_or_conditional)'
32
33 %description
34
35 %description -l de
36
37 %description -l es
38
39 %description -l fr
40
41 %description -l pl
42
43 %description -l ru
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47 %patch0 -p1
48
49 %build
50 # Don't use pipes here: they generally don't work. Apply a patch.
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53
54 %{__make}
55 # if module isn't noarch, use:
56 # %{__make} \
57 #       OPTIMIZE="%{rpmcflags}"
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 # use macros:
74 #%%{perl_vendorlib}/...
75 #%%{perl_vendorarch}/...
76 %{_mandir}/man3/*
This page took 0.031875 seconds and 4 git commands to generate.