]> git.pld-linux.org Git - projects/template-specs.git/blob - perl.spec
- updated _noauto for new wrappers
[projects/template-specs.git] / perl.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    -
7 %define pnam    -
8 Summary:        -
9 Summary(de):    -
10 Summary(es):    -
11 Summary(fr):    -
12 Summary(pl):    -
13 Summary(ru):    -
14 Name:           perl-
15 Version:        -
16 Release:        -
17 Epoch:          -
18 License:        (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
19 Group:          Development/Languages/Perl
20 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
21 Patch0:         %{name}
22 URL:            -
23 BuildRequires:  perl-devel >= 5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  -
26 Requires:       -
27 Prereq:         -
28 Provides:       -
29 Obsoletes:      -
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreq      'perl(anything_fake_or_conditional)'
34
35 %description
36
37 %description -l de
38
39 %description -l es
40
41 %description -l fr
42
43 %description -l pl
44
45 %description -l ru
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49 %patch0 -p1
50
51 %build
52 # Don't use pipes here: they generally don't work. Apply a patch.
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55
56 %{__make}
57 # if module isn't noarch, use:
58 # %{__make} \
59 #       OPTIMIZE="%{rpmcflags}"
60
61 %{!?_without_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 # use macros:
76 #%%{perl_vendorlib}/...
77 #%%{perl_vendorarch}/...
78 %{_mandir}/man3/*
This page took 0.714417 seconds and 4 git commands to generate.