]> git.pld-linux.org Git - packages/perl-YAML-LibYAML.git/blob - perl-YAML-LibYAML.spec
- perl req/prov fix
[packages/perl-YAML-LibYAML.git] / perl-YAML-LibYAML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    YAML
7 %define pnam    LibYAML
8 Summary:        YAML::XS::LibYAML - An XS Wrapper Module of libyaml
9 Summary(pl.UTF-8):      YAML::XS::LibYAML - moduł wrappera XS dla libyaml
10 Name:           perl-YAML-LibYAML
11 Version:        0.59
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  733e63b743088781eb8cad6477cd4905
18 URL:            http://search.cpan.org/dist/YAML-LibYAML/
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 YAML::XS is a Perl YAML implementation using XS and libyaml.
25
26 YAML::XS::LibYAML is an XS wrapper module for libyaml.
27
28 %description -l pl.UTF-8
29 YAML::XS to perlowa implementacja YAML-a przy użyciu XS i biblioteki
30 libyaml.
31
32 YAML::XS::LibYAML to moduł wrappera XS dla libyaml.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/YAML/*.pod
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/YAML/LibYAML.pm
61 %{perl_vendorarch}/YAML/XS.pm
62 %{perl_vendorarch}/YAML/XS
63 %dir %{perl_vendorarch}/auto/YAML/XS
64 %dir %{perl_vendorarch}/auto/YAML/XS/LibYAML
65 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/XS/LibYAML/LibYAML.so
66 %{_mandir}/man3/YAML::LibYAML.3pm*
67 %{_mandir}/man3/YAML::XS.3pm*
68 %{_mandir}/man3/YAML::XS::LibYAML.3pm*
This page took 0.040045 seconds and 3 git commands to generate.