]> git.pld-linux.org Git - packages/perl-TimeDate.git/blob - perl-TimeDate.spec
- updated to 2.33
[packages/perl-TimeDate.git] / perl-TimeDate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Time
6 %define         pnam    Date
7 Summary:        Manipulating timezones and parsing/formatting dates in Perl
8 Summary(pl.UTF-8):      Manipulowanie strefami czasowymi i analizowanie/formatowanie dat w Perlu
9 Name:           perl-TimeDate
10 Version:        2.33
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Time/%{pdir}%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5e5afe22c8d417417283d1f7f4572a57
18 URL:            https://metacpan.org/release/TimeDate
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 TimeDate contains Date::Format, Date::Parse and Time::Zone.
26
27 Date::Format provides routines to format dates into ASCII strings.
28 They correspond to the C library routines strftime() and ctime().
29
30 Date::Parse provides two routines for parsing date strings into time
31 values: str2time(DATE [, ZONE]) and strptime(DATE [, ZONE]).
32
33 Time::Zone contains miscellaneous timezone manipulations routines.
34
35 %description -l pl.UTF-8
36 TimeDate zawiera moduły: Date::Format, Date::Parse i Time::Zone.
37
38 Date::Format dostarcza funkcje, formatujące datę w ciągi ASCII.
39 Funkcje te odpowiadają strftime() i ctime() z biblioteki C.
40
41 Date::Parse udostępnia dwie funkcje do zamiany ciągów ASCII na
42 wartości time: str2time(DATE [, ZONE]) oraz strptime(DATE [, ZONE]).
43
44 Time::Zone zawiera różne funkcje, służące do manipulowania strefami
45 czasowymi.
46
47 %prep
48 %setup -q -n %{pdir}%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc ChangeLog README
69 %{perl_vendorlib}/Date/Format.pm
70 %{perl_vendorlib}/Date/Language.pm
71 %{perl_vendorlib}/Date/Parse.pm
72 %dir %{perl_vendorlib}/Date/Language
73 %{perl_vendorlib}/Date/Language/*.pm
74 %{perl_vendorlib}/Time/Zone.pm
75 %{perl_vendorlib}/TimeDate.pm
76 %{_mandir}/man3/Date::Format.3pm*
77 %{_mandir}/man3/Date::Language.3pm*
78 %{_mandir}/man3/Date::Language::Bulgarian.3pm*
79 %{_mandir}/man3/Date::Language::Hungarian.3pm*
80 %{_mandir}/man3/Date::Parse.3pm*
81 %{_mandir}/man3/Time::Zone.3pm*
82 %{_mandir}/man3/TimeDate.3pm.gz
This page took 0.112485 seconds and 4 git commands to generate.