]> git.pld-linux.org Git - packages/perl-Test-Mock-Guard.git/blob - perl-Test-Mock-Guard.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Mock-Guard.git] / perl-Test-Mock-Guard.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Mock-Guard
7 Summary:        Test::Mock::Guard - Simple mock test library using RAII
8 Name:           perl-Test-Mock-Guard
9 Version:        0.10
10 Release:        1
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  b2866485cc29c787f85793279e2f2360
15 URL:            https://metacpan.org/release/Test-Mock-Guard/
16 BuildRequires:  perl-Module-Build
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Class-Load >= 0.06
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Test::Mock::Guard is mock test library using RAII. This module is able
27 to change method behavior by each scope. See SYNOPSIS's sample code.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Build.PL \
34         destdir=$RPM_BUILD_ROOT \
35         installdirs=vendor
36 ./Build
37
38 %{?with_tests:./Build test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 ./Build install
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes
51 %{perl_vendorlib}/Test/Mock/Guard.pm
52 %{_mandir}/man3/*
This page took 0.070625 seconds and 3 git commands to generate.