]> git.pld-linux.org Git - packages/perl-Test-Mock-Guard.git/blob - perl-Test-Mock-Guard.spec
2d7284b1a6d53df98478e0a2344f48898ab44826
[packages/perl-Test-Mock-Guard.git] / perl-Test-Mock-Guard.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Mock-Guard
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::Mock::Guard - Simple mock test library using RAII
9 Name:           perl-Test-Mock-Guard
10 Version:        0.10
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  b2866485cc29c787f85793279e2f2360
16 URL:            https://metacpan.org/release/Test-Mock-Guard/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Load >= 0.06
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Test::Mock::Guard is mock test library using RAII. This module is able
28 to change method behavior by each scope. See SYNOPSIS's sample code.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Build.PL \
35         destdir=$RPM_BUILD_ROOT \
36         installdirs=vendor
37 ./Build
38
39 %{?with_tests:./Build test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 ./Build install
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes
52 %{perl_vendorlib}/Test/Mock/Guard.pm
53 %{_mandir}/man3/*
This page took 0.035043 seconds and 2 git commands to generate.