]> git.pld-linux.org Git - packages/perl-Term-ReadKey.git/blob - perl-Term-ReadKey.spec
- add CC to %{__make}
[packages/perl-Term-ReadKey.git] / perl-Term-ReadKey.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # requires terminal
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Term
8 %define         pnam    ReadKey
9 Summary:        Term::ReadKey Perl module
10 Summary(cs.UTF-8):      Modul Term::ReadKey pro Perl
11 Summary(da.UTF-8):      Perlmodul Term::ReadKey
12 Summary(de.UTF-8):      Term::ReadKey Perl Modul
13 Summary(es.UTF-8):      Módulo de Perl Term::ReadKey
14 Summary(fr.UTF-8):      Module Perl Term::ReadKey
15 Summary(it.UTF-8):      Modulo di Perl Term::ReadKey
16 Summary(ja.UTF-8):      Term::ReadKey Perl モジュール
17 Summary(ko.UTF-8):      Term::ReadKey 펄 모줄
18 Summary(nb.UTF-8):      Perlmodul Term::ReadKey
19 Summary(pl.UTF-8):      Moduł Perla Term::ReadKey
20 Summary(pt.UTF-8):      Módulo de Perl Term::ReadKey
21 Summary(pt_BR.UTF-8):   Módulo Perl Term::ReadKey
22 Summary(ru.UTF-8):      Модуль для Perl Term::ReadKey
23 Summary(sv.UTF-8):      Term::ReadKey Perlmodul
24 Summary(uk.UTF-8):      Модуль для Perl Term::ReadKey
25 Summary(zh_CN.UTF-8):   Term::ReadKey Perl 模块
26 Name:           perl-Term-ReadKey
27 Version:        2.30
28 Release:        1
29 License:        BSD-like
30 Group:          Development/Languages/Perl
31 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}%{pnam}-%{version}.tar.gz
32 # Source0-md5:  f0ef2cea8acfbcc58d865c05b0c7e1ff
33 BuildRequires:  perl-devel >= 1:5.8.0
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 Obsoletes:      perl-%{pdir}%{pnam}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This module, ReadKey, provides ioctl control for terminals so the
40 input modes can be changed (thus allowing reads of a single character
41 at a time), and also provides non-blocking reads of stdin, as well as
42 several other terminal related features, including
43 retrieval/modification of the screen size, and retrieval/modification
44 of the control characters.
45
46 %description -l pl.UTF-8
47 Moduł Perla Term::ReadKey. Moduł ten daje obsługę ioctl dla terminali,
48 umożliwiając zmianę trybu wejścia (co pozwala na czytanie po jednym
49 znaku) oraz nieblokujący odczyt z wejścia, a także inne funkcje
50 związane z terminalem, w tym odczytywanie i modyfikowanie rozmiaru
51 ekranu oraz odczytywanie i modyfikowanie znaków kontrolnych.
52
53 %description -l pt_BR.UTF-8
54 Este módulo fornece controle via ioctl para terminais, de tal forma
55 que seus modos de entrada possam ser modificados (desta forma
56 permitindo a leitura de um caracter somente por vez) e também fornece
57 leitura não bloqueantes da entrada padrão (stdin), bem como várias
58 outras características relacionadas a terminais, entre elas a
59 recuperação/modificação do tamanho da tela e dos caracteres de
60 controle.
61
62 %prep
63 %setup -q -n TermReadKey-%{version}
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor
68 %{__make} \
69         CC="%{__cc}" \
70         OPTIMIZE="%{rpmcflags}"
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README
86 %{perl_vendorarch}/Term/ReadKey.pm
87 %dir %{perl_vendorarch}/auto/Term/ReadKey
88 # empty autosplit.ix
89 #%%{perl_vendorarch}/auto/Term/ReadKey/autosplit.ix
90 %{perl_vendorarch}/auto/Term/ReadKey/ReadKey.bs
91 %attr(755,root,root) %{perl_vendorarch}/auto/Term/ReadKey/ReadKey.so
92 %{_mandir}/man3/*
This page took 0.030445 seconds and 4 git commands to generate.