]> git.pld-linux.org Git - packages/perl-Params-Validate.git/blob - perl-Params-Validate.spec
- up to 0.69
[packages/perl-Params-Validate.git] / perl-Params-Validate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Params
7 %define pnam    Validate
8 Summary:        Params::Validate - validate method/function parameters
9 Summary(pl):    Params::Validate - sprawdzanie poprawno¶ci parametrów funkcji/metody
10 Name:           perl-Params-Validate
11 Version:        0.69
12 Release:        1
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/authors/id/D/DR/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c0e31f95ac8065c52a3cc18ad7be03f0
18 %if %{with tests}
19 BuildRequires:  perl-Attribute-Handlers
20 BuildRequires:  perl-Test-Simple
21 %endif
22 BuildRequires:  perl-devel >= 5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Params::Validate module allows you to validate method or function
28 call parameters to an arbitrary level of specificity.  At the simplest
29 level, it is capable of validating the required parameters were given
30 and that no unspecified additional parameters were passed in.
31
32 It is also capable of determining that a parameter is of a specific
33 type, that it is an object of a certain class hierarchy, that it
34 possesses certain methods, or applying validation callbacks to
35 arguments.
36
37 %description -l pl
38 Modu³ Params::Validate pozwala na sprawdzanie poprawno¶ci parametrów,
39 z jakimi wywo³ana zosta³a funkcja lub metoda, na dowolnym poziomie
40 szczegó³owo¶ci.  W najprostrzym przypadku mo¿liwe jest sprawdzenie,
41 czy podane zosta³y parametry wymagane i czy nie podano dodatkowych,
42 nie rozpoznawanych.
43
44 Potrafi tak¿e okre¶liæ czy parametr jest konkretnego typu, czy jest
45 obiektem danej hierarchii, czy posiada zadane metody, lub przypisaæ
46 argumentom callbacki (a, i tak wszyscy wiedz±, o co chodzi... ;-> )
47 sprawdzaj±ce.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make} \
56         OPTIMIZE="%{rpmcflags}"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %dir %{perl_vendorarch}/auto/Params
73 %dir %{perl_vendorarch}/auto/Params/Validate
74 %{perl_vendorarch}/auto/Params/Validate/*.bs
75 %attr(755,root,root) %{perl_vendorarch}/auto/Params/Validate/*.so
76 %dir %{perl_vendorarch}/Attribute
77 %dir %{perl_vendorarch}/Attribute/Params
78 %{perl_vendorarch}/Attribute/Params/*.pm
79 %dir %{perl_vendorarch}/Params
80 %{perl_vendorarch}/Params/*.pm
81 %{_mandir}/man3/*
This page took 0.840884 seconds and 3 git commands to generate.