]> git.pld-linux.org Git - packages/perl-Params-Validate.git/blob - perl-Params-Validate.spec
- standarized Source0 URL
[packages/perl-Params-Validate.git] / perl-Params-Validate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Params
7 %define         pnam    Validate
8 Summary:        Params::Validate - validate method/function parameters
9 Summary(pl):    Params::Validate - sprawdzanie poprawno¶ci parametrów funkcji/metody
10 Name:           perl-Params-Validate
11 Version:        0.76
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/D/DR/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  111783087f92dd6a99df5d1aeaa16c27
18 %if %{with tests}
19 BuildRequires:  perl-Attribute-Handlers
20 BuildRequires:  perl-Test-Simple
21 BuildRequires:  perl-Test-Taint
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Params::Validate module allows you to validate method or function
29 call parameters to an arbitrary level of specificity.  At the simplest
30 level, it is capable of validating the required parameters were given
31 and that no unspecified additional parameters were passed in.
32
33 It is also capable of determining that a parameter is of a specific
34 type, that it is an object of a certain class hierarchy, that it
35 possesses certain methods, or applying validation callbacks to
36 arguments.
37
38 %description -l pl
39 Modu³ Params::Validate pozwala na sprawdzanie poprawno¶ci parametrów,
40 z jakimi wywo³ana zosta³a funkcja lub metoda, na dowolnym poziomie
41 szczegó³owo¶ci.  W najprostszym przypadku mo¿liwe jest sprawdzenie,
42 czy podane zosta³y parametry wymagane i czy nie podano dodatkowych,
43 nie rozpoznawanych.
44
45 Potrafi tak¿e okre¶liæ czy parametr jest konkretnego typu, czy jest
46 obiektem danej hierarchii, czy posiada zadane metody, lub przypisaæ
47 argumentom callbacki (a, i tak wszyscy wiedz±, o co chodzi... ;-> )
48 sprawdzaj±ce.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make} \
57         OPTIMIZE="%{rpmcflags}"
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %dir %{perl_vendorarch}/auto/%{pdir}
74 %dir %{perl_vendorarch}/auto/%{pdir}/%{pnam}
75 %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.bs
76 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.so
77 %dir %{perl_vendorarch}/Attribute
78 %dir %{perl_vendorarch}/Attribute/%{pdir}
79 %{perl_vendorarch}/Attribute/%{pdir}/*.pm
80 %dir %{perl_vendorarch}/%{pdir}
81 %{perl_vendorarch}/%{pdir}/*.pm
82 %{_mandir}/man3/*
This page took 0.036773 seconds and 3 git commands to generate.