]> git.pld-linux.org Git - packages/perl-Params-Validate.git/blob - perl-Params-Validate.spec
- rel 2
[packages/perl-Params-Validate.git] / perl-Params-Validate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Params
7 %define         pnam    Validate
8 Summary:        Params::Validate - validate method/function parameters
9 Summary(pl.UTF-8):      Params::Validate - sprawdzanie poprawności parametrów funkcji/metody
10 Name:           perl-Params-Validate
11 Version:        0.89
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/D/DR/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b53ff2b9595623aaa4f98d8b31a5a1c2
18 URL:            http://search.cpan.org/dist/Params-Validate/
19 %if %{with tests}
20 BuildRequires:  perl-Attribute-Handlers
21 BuildRequires:  perl-Test-Simple
22 BuildRequires:  perl-Test-Taint
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Params::Validate module allows you to validate method or function
30 call parameters to an arbitrary level of specificity.  At the simplest
31 level, it is capable of validating the required parameters were given
32 and that no unspecified additional parameters were passed in.
33
34 It is also capable of determining that a parameter is of a specific
35 type, that it is an object of a certain class hierarchy, that it
36 possesses certain methods, or applying validation callbacks to
37 arguments.
38
39 %description -l pl.UTF-8
40 Moduł Params::Validate pozwala na sprawdzanie poprawności parametrów,
41 z jakimi wywołana została funkcja lub metoda, na dowolnym poziomie
42 szczegółowości.  W najprostszym przypadku możliwe jest sprawdzenie,
43 czy podane zostały parametry wymagane i czy nie podano dodatkowych,
44 nie rozpoznawanych.
45
46 Potrafi także określić czy parametr jest konkretnego typu, czy jest
47 obiektem danej hierarchii, czy posiada zadane metody, lub przypisać
48 argumentom callbacki (a, i tak wszyscy wiedzą, o co chodzi... ;-> )
49 sprawdzające.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make} \
58         CC="%{__cc}" \
59         OPTIMIZE="%{rpmcflags}"
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %dir %{perl_vendorarch}/auto/Params
76 %dir %{perl_vendorarch}/auto/Params/Validate
77 %{perl_vendorarch}/auto/Params/Validate/*.bs
78 %attr(755,root,root) %{perl_vendorarch}/auto/Params/Validate/*.so
79 %dir %{perl_vendorarch}/Attribute
80 %dir %{perl_vendorarch}/Attribute/Params
81 %{perl_vendorarch}/Attribute/Params/*.pm
82 %dir %{perl_vendorarch}/Params
83 %{perl_vendorarch}/Params/*.pm
84 %{_mandir}/man3/*
This page took 0.026331 seconds and 3 git commands to generate.