]> git.pld-linux.org Git - packages/perl-Params-Validate.git/blob - perl-Params-Validate.spec
- missing BR
[packages/perl-Params-Validate.git] / perl-Params-Validate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Params
7 %define pnam    Validate
8 Summary:        Params::Validate - validate method/function parameters
9 Summary(pl):    Params::Validate - sprawdzanie poprawno¶ci parametrów funkcji/metody
10 Name:           perl-Params-Validate
11 Version:        0.74
12 Release:        1
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/authors/id/D/DR/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e693fbbcdaed67a5a8d0e6cd3141d0ce
18 %if %{with tests}
19 BuildRequires:  perl-Attribute-Handlers
20 BuildRequires:  perl-Test-Simple
21 # Not in PLD yet
22 #BuildRequires: perl-Test-Taint
23 %endif
24 BuildRequires:  perl-devel >= 5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Params::Validate module allows you to validate method or function
30 call parameters to an arbitrary level of specificity.  At the simplest
31 level, it is capable of validating the required parameters were given
32 and that no unspecified additional parameters were passed in.
33
34 It is also capable of determining that a parameter is of a specific
35 type, that it is an object of a certain class hierarchy, that it
36 possesses certain methods, or applying validation callbacks to
37 arguments.
38
39 %description -l pl
40 Modu³ Params::Validate pozwala na sprawdzanie poprawno¶ci parametrów,
41 z jakimi wywo³ana zosta³a funkcja lub metoda, na dowolnym poziomie
42 szczegó³owo¶ci.  W najprostszym przypadku mo¿liwe jest sprawdzenie,
43 czy podane zosta³y parametry wymagane i czy nie podano dodatkowych,
44 nie rozpoznawanych.
45
46 Potrafi tak¿e okre¶liæ czy parametr jest konkretnego typu, czy jest
47 obiektem danej hierarchii, czy posiada zadane metody, lub przypisaæ
48 argumentom callbacki (a, i tak wszyscy wiedz±, o co chodzi... ;-> )
49 sprawdzaj±ce.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make} \
58         OPTIMIZE="%{rpmcflags}"
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %dir %{perl_vendorarch}/auto/%{pdir}
75 %dir %{perl_vendorarch}/auto/%{pdir}/%{pnam}
76 %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.bs
77 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/*.so
78 %dir %{perl_vendorarch}/Attribute
79 %dir %{perl_vendorarch}/Attribute/%{pdir}
80 %{perl_vendorarch}/Attribute/%{pdir}/*.pm
81 %dir %{perl_vendorarch}/%{pdir}
82 %{perl_vendorarch}/%{pdir}/*.pm
83 %{_mandir}/man3/*
This page took 0.049726 seconds and 3 git commands to generate.