]> git.pld-linux.org Git - packages/perl-PAR-Packer.git/blob - perl-PAR-Packer.spec
9e0e58492fd6d49a07aa4c3ce2e7695ec1ff7903
[packages/perl-PAR-Packer.git] / perl-PAR-Packer.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    PAR
7 %define pnam    Packer
8 Summary:        PAR::Packer - PAR Packager
9 #Summary(pl.UTF-8):     
10 Name:           perl-PAR-Packer
11 Version:        0.982
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/PAR/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8f78dcc541758efca6f3c3b98e1124ae
18 URL:            http://search.cpan.org/dist/PAR-Packer/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Archive-Zip >= 1
23 BuildRequires:  perl-Getopt-ArgvFile >= 1.07
24 BuildRequires:  perl-Module-ScanDeps >= 0.78
25 BuildRequires:  perl-PAR >= 0.977
26 BuildRequires:  perl-PAR-Dist >= 0.22
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module implements the App::Packer::Backend interface, for generating
32 stand-alone executables, perl scripts and PAR files.
33
34 # %description -l pl.UTF-8
35 # TODO
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc AUTHORS ChangeLog README TODO
61 %attr(755,root,root) %{_bindir}/*
62 %{perl_vendorlib}/*.pm
63 %{perl_vendorlib}/PAR/*
64 %{perl_vendorlib}/App/Packer/*
65 %{_mandir}/man?/*
This page took 0.047744 seconds and 2 git commands to generate.