]> git.pld-linux.org Git - packages/perl-PAR-Packer.git/blob - perl-PAR-Packer.spec
- release 2: separated /usr/bin/tkpp (requires perl-Tk)
[packages/perl-PAR-Packer.git] / perl-PAR-Packer.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    PAR
7 %define pnam    Packer
8 Summary:        PAR::Packer - PAR Packager
9 #Summary(pl.UTF-8):     
10 Name:           perl-PAR-Packer
11 Version:        0.982
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/PAR/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8f78dcc541758efca6f3c3b98e1124ae
18 URL:            http://search.cpan.org/dist/PAR-Packer/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Archive-Zip >= 1
23 BuildRequires:  perl-Getopt-ArgvFile >= 1.07
24 BuildRequires:  perl-Module-ScanDeps >= 0.78
25 BuildRequires:  perl-PAR >= 0.977
26 BuildRequires:  perl-PAR-Dist >= 0.22
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module implements the App::Packer::Backend interface, for generating
32 stand-alone executables, perl scripts and PAR files.
33
34 # %description -l pl.UTF-8
35 # TODO
36
37 %package tkpp
38 Summary:        tkpp - frontend to pp written in Perl/Tk
39 Group:          Development/Tools
40 Requires:       %{name} = %{version}-%{release}
41
42 %description tkpp
43 Tkpp is a GUI frontend to pp, which can turn perl scripts into stand-alone
44 PAR files, perl scripts or executables.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc AUTHORS ChangeLog README TODO
70 %attr(755,root,root) %{_bindir}/p*
71 %{perl_vendorlib}/*.pm
72 %{perl_vendorlib}/PAR/*
73 %{perl_vendorlib}/App/Packer/*
74 %{_mandir}/man3/*
75 %{_mandir}/man1/p*
76
77 %files tkpp
78 %attr(755,root,root) %{_bindir}/tkpp
79 %{_mandir}/man1/tkpp*
This page took 0.048949 seconds and 3 git commands to generate.