]> git.pld-linux.org Git - packages/perl-Net-SSLeay.git/blob - perl-Net-SSLeay.spec
- generic URL
[packages/perl-Net-SSLeay.git] / perl-Net-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Net::SSLeay - Perl extension for using OpenSSL or SSLeay
7 Summary(pl.UTF-8):      Net::SSLeay - rozszerzenie Perla do używania OpenSSL lub SSLeay
8 Name:           perl-Net-SSLeay
9 Version:        1.25
10 Release:        3
11 # same as openssl
12 License:        Apache-style License
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/Net_SSLeay.pm-%{version}.tar.gz
15 # Source0-md5:  87de8a06802fbb63c7c85e89eedbe139
16 Patch0:         %{name}-paths.patch
17 URL:            http://search.cpan.org/dist/Net_SSLeay.pm/
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  openssl-tools >= 0.9.7d
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module offers some high level convinience functions for accessing
26 web pages on SSL servers, a sslcat() function for writing your own
27 clients, and finally access to the SSL api of SSLeay/OpenSSL package
28 so you can write servers or clients for more complicated applications.
29
30 %description -l pl.UTF-8
31 Ten moduł oferuje kilka wygodnych funkcji wysokiego poziomu służących
32 do dostępu do stron WWW na serwerach SSL, funkcję sslcat() do pisania
33 własnych klientów, oraz dostęp do API SSL pakietu SSLeay/OpenSSL, co
34 pozwala na pisanie serwerów lub klientów dla bardziej skomplikowanych
35 aplikacji.
36
37 %prep
38 %setup -q -n Net_SSLeay.pm-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL %{_prefix} \
43         INSTALLDIRS=vendor
44 %{__make} \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55 install examples/*.{pl,conf} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes Credits README
63 %{perl_vendorarch}/Net/SSLeay.pm
64 %{perl_vendorarch}/Net/SSLeay
65 %{perl_vendorarch}/Net/ptrtstrun.pl
66 %dir %{perl_vendorarch}/auto/Net/SSLeay
67 %{perl_vendorarch}/auto/Net/SSLeay/autosplit.ix
68 %{perl_vendorarch}/auto/Net/SSLeay/*.al
69 %{perl_vendorarch}/auto/Net/SSLeay/*.bs
70 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSLeay/*.so
71 %{_mandir}/man3/*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.088145 seconds and 4 git commands to generate.