]> git.pld-linux.org Git - packages/perl-Net-SSLeay.git/blob - perl-Net-SSLeay.spec
ad39d39b4b3a8187f605da96127b508e80c6c1a7
[packages/perl-Net-SSLeay.git] / perl-Net-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Net::SSLeay - Perl extension for using OpenSSL or SSLeay
7 Summary(pl):    Net::SSLeay - rozszerzenie Perla do u¿ywania OpenSSL lub SSLeay
8 Name:           perl-Net-SSLeay
9 Version:        1.25
10 Release:        2
11 # same as openssl
12 License:        Apache-style License
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/Net_SSLeay.pm-%{version}.tar.gz
15 # Source0-md5:  87de8a06802fbb63c7c85e89eedbe139
16 Patch0:         %{name}-paths.patch
17 BuildRequires:  openssl-devel >= 0.9.7d
18 BuildRequires:  openssl-tools >= 0.9.7d
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module offers some high level convinience functions for accessing
25 web pages on SSL servers, a sslcat() function for writing your own
26 clients, and finally access to the SSL api of SSLeay/OpenSSL package
27 so you can write servers or clients for more complicated applications.
28
29 %description -l pl
30 Ten modu³ oferuje kilka wygodnych funkcji wysokiego poziomu s³u¿±cych
31 do dostêpu do stron WWW na serwerach SSL, funkcjê sslcat() do pisania
32 w³asnych klientów, oraz dostêp do API SSL pakietu SSLeay/OpenSSL, co
33 pozwala na pisanie serwerów lub klientów dla bardziej skomplikowanych
34 aplikacji.
35
36 %prep
37 %setup -q -n Net_SSLeay.pm-%{version}
38 %patch0 -p1
39
40 %build
41 %{__perl} Makefile.PL %{_prefix} \
42         INSTALLDIRS=vendor
43 %{__make} \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 install examples/*.{pl,conf} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes Credits README
62 %{perl_vendorarch}/Net/SSLeay.pm
63 %{perl_vendorarch}/Net/SSLeay
64 %{perl_vendorarch}/Net/ptrtstrun.pl
65 %dir %{perl_vendorarch}/auto/Net/SSLeay
66 %{perl_vendorarch}/auto/Net/SSLeay/autosplit.ix
67 %{perl_vendorarch}/auto/Net/SSLeay/*.al
68 %{perl_vendorarch}/auto/Net/SSLeay/*.bs
69 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSLeay/*.so
70 %{_mandir}/man3/*
71 %{_examplesdir}/%{name}-%{version}
This page took 0.054375 seconds and 3 git commands to generate.