]> git.pld-linux.org Git - packages/perl-Nagios-Plugin.git/blob - perl-Nagios-Plugin.spec
- missing dir
[packages/perl-Nagios-Plugin.git] / perl-Nagios-Plugin.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Nagios
7 %define pnam    Plugin
8 Summary:        Nagios::Plugin - A family of perl modules to streamline writing Nagios plugins
9 Name:           perl-Nagios-Plugin
10 Version:        0.23
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/T/TO/TONVOON/Nagios-Plugin-%{version}.tar.gz
16 # Source0-md5:  7eb466f122ea83788506d78d7bf2c402
17 URL:            http://search.cpan.org/dist/Nagios-Plugin/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::Accessor)
22 BuildRequires:  perl(Config::Tiny)
23 BuildRequires:  perl(Math::Calc::Units)
24 BuildRequires:  perl(Params::Validate)
25 BuildRequires:  perl(Test::More) >= 0.62
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Nagios::Plugin and its associated Nagios::Plugin::* modules are a
32 family of Perl modules to streamline writing Nagios plugins. The main
33 end user modules are Nagios::Plugin, providing an object-oriented
34 interface to the entire Nagios::Plugin::* collection, and
35 Nagios::Plugin::Functions, providing a simpler functional interface to
36 a useful subset of the available functionality.
37
38 The purpose of the collection is to make it as simple as possible for
39 developers to create plugins that conform the Nagios Plugin guidelines
40 <http://nagiosplug.sourceforge.net/developer-guidelines.html>.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %dir %{perl_vendorlib}/Nagios
65 %{perl_vendorlib}/Nagios/*.pm
66 %{perl_vendorlib}/Nagios/Plugin
67 %{_mandir}/man3/*
This page took 0.059621 seconds and 4 git commands to generate.