]> git.pld-linux.org Git - packages/perl-Math-GSL.git/blob - perl-Math-GSL.spec
5685276b4ec967c8ce596526fcfa07e1f3e73b80
[packages/perl-Math-GSL.git] / perl-Math-GSL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    GSL
7 Summary:        Math::GSL Perl module - resticted interface to GNU Scientific Library
8 Summary(pl.UTF-8):      Moduł Perla Math::GSL - ograniczony interfejs do GNU Scientific Library
9 Name:           perl-Math-GSL
10 Version:        0.39
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6bbcb412e230d3e1602164e15767d102
17 Patch0:         %{name}-inc.patch
18 Patch1:         %{name}-update.patch
19 URL:            http://search.cpan.org/dist/Math-GSL/
20 BuildRequires:  gsl-devel >= 1.15
21 BuildRequires:  perl-Module-Build >= 0.38
22 BuildRequires:  perl-PkgConfig >= 0.07720
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  swig-perl
26 %if %{with tests}
27 BuildRequires:  perl-Test-Class >= 0.12
28 BuildRequires:  perl-Test-Deep
29 BuildRequires:  perl-Test-Differences
30 BuildRequires:  perl-Test-Exception >= 0.21
31 BuildRequires:  perl-Test-Most >= 0.31
32 BuildRequires:  perl-Test-Taint >= 1.06
33 BuildRequires:  perl-Test-Warn
34 BuildRequires:  perl-version >= 0.77
35 %endif
36 Requires:       gsl >= 1.15
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Math::GSL Perl module is a very resticted perl interface to -lgsl -
41 GNU Scientific Library. Only the routines relating the solving of
42 polynomials are exported. It exists to provide that function to
43 "tkscope" in Audio::Data.
44
45 %description -l pl.UTF-8
46 Moduł Perla Math::GSL stanowi bardzo ograniczony interfejs do -lgsl -
47 Biblioteki Naukowej GNU (GNU Scientific Library). Eksportuje jedynie
48 funkcje dotyczące rozwiązywania równań wielomianowych. Istnieje, aby
49 udostępnić te funkcje "tkscope" w module Audio::Data.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53 %patch0 -p1
54 %patch1 -p1
55
56 # simulate non-release to force swig rebuild
57 mkdir .git
58
59 %build
60 export CC_FLAGS="%{rpmcppflags} %{rpmcflags}"
61 %{__perl} Build.PL \
62         destdir=$RPM_BUILD_ROOT \
63         installdirs=vendor
64 ./Build
65
66 %{?with_tests:./Build test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 ./Build install
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CREDITS Changes KNOWN_BUGS README.md TODO
79 %{perl_vendorarch}/Math/GSL.pm
80 %{perl_vendorarch}/Math/GSL
81 %dir %{perl_vendorarch}/auto/Math/GSL
82 %dir %{perl_vendorarch}/auto/Math/GSL/*
83 %attr(755,root,root) %{perl_vendorarch}/auto/Math/GSL/*/*.so
84 %{_mandir}/man3/Math::GSL*.3pm*
This page took 0.086117 seconds and 2 git commands to generate.