]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
f3139954535bf4560f501e05980755c7e5a567cb
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test" - needs network connection
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    IO
7 %define pnam    Socket-SSL
8 Summary:        IO::Socket::SSL -- Nearly transparent SSL encapsulation for IO::Socket::INET
9 Summary(pl):    IO::Socket::SSL -- prawie przezroczysta obudowa SSL dla IO::Socket::INET
10 Name:           perl-IO-Socket-SSL
11 Version:        0.92
12 Release:        2
13 Epoch:          1
14 License:        GPL
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c4757e406591dcfb1e068d0156a33601
18 BuildRequires:  perl-devel >= 5.6
19 BuildRequires:  perl-Net-SSLeay
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module is a true drop-in replacement for IO::Socket::INET that
26 uses SSL to encrypt data before it is transferred to a remote server
27 or client. IO::Socket::SSL supports all the extra features that one
28 needs to write a full-featured SSL client or server application:
29 multiple SSL contexts, cipher selection, certificate verification, and
30 SSL version selection. As an extra bonus, it works perfectly with
31 mod_perl.
32
33 %description -l pl
34 Ten modu³ jest prawdziwym zamiennikiem dla IO::Socket::INET,
35 u¿ywaj±cym SSL do kodowania danych przed przesy³aniem do zdalnego
36 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
37 rzeczy potrzebne do napisania w pe³ni funkcjonalnego klienta lub
38 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
39 certyfikatu, wybór wersji SSL. Ponadto wspaniale dzia³a z mod_perlem.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor 
47 %{__make}
48
49 %{?_with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 install example/* util/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Change* README docs/*
65 %{perl_vendorlib}/IO/Socket/SSL.pm
66 %{_mandir}/man3/*
67 %{_examplesdir}/%{name}-%{version}
This page took 0.052156 seconds and 3 git commands to generate.